Results 1 to 3 of 3
Like Tree3Likes
  • 3 Post By DesigningByCoffee

Thread: e-61 issue need advice

  1. #1
    Member
    Join Date
    May 2008
    Location
    Newcastle NSW Australia
    Posts
    85

    e-61 issue need advice

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi all I own a Rocket Giotto V2 approx 3 YO and noticed an issue for the first time the other day. After brewing a coffee I returned the lever to the off position only to find the brew cycle continued. Startled by this I quickly raised the lever and lowered it again and this time the cycle stopped. This has now happened randomly 3 times in the last week. Twice when brewing a coffee and once when back flushing. After the first episode I gave machine a chemical backflush but problem is still there.(I use chemicals approx each month) I have always used filtered water and backflush after each use. Leaver is not stiff or squeaking. Any advice appreciated.
    .

  2. #2
    Life-long Learner DesigningByCoffee's Avatar
    Join Date
    Aug 2008
    Location
    Millthorpe NSW
    Posts
    2,038
    Sounds like first port of call would be the micro-switch. Raising the lever does mechanical things inside the group, but the cam on the back also depresses the microswitch that pokes out of the body. This is what will start/stop the pump. Perhaps there is a loose wire in there, or the switch itself is coming loose? If this is fine, it will most likely be further back towards the control board - but that is moving towards techie land
    Cicarda, Dimal and Yelta like this.

  3. #3
    Member
    Join Date
    May 2008
    Location
    Newcastle NSW Australia
    Posts
    85
    Quote Originally Posted by DesigningByCoffee View Post
    Sounds like first port of call would be the micro-switch. Raising the lever does mechanical things inside the group, but the cam on the back also depresses the microswitch that pokes out of the body. This is what will start/stop the pump. Perhaps there is a loose wire in there, or the switch itself is coming loose? If this is fine, it will most likely be further back towards the control board - but that is moving towards techie land
    Thanks for the advice will check out that microswitch first. Will make sure its popping back out when it should first then check the possible loose wire scenario and beyond Will also see if it is only occurring when there is back pressure through the system. The problem has not occurred for the past 2 days so hope that gremlin will not resurface and just keep making coffees the way it should!
    Any further thoughts would be appreciated will post any outcomes.
    Thanks Cicarda



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •