Results 1 to 12 of 12
Like Tree7Likes
  • 1 Post By TC
  • 1 Post By Casa Espresso
  • 1 Post By Casa Espresso
  • 1 Post By TC
  • 1 Post By coffeehoon
  • 2 Post By coffeehoon

Thread: New Bezzera Bz10 issues

  1. #1
    Junior Member
    Join Date
    Jun 2014
    Posts
    26

    New Bezzera Bz10 issues

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hiya folks,

    I've seen quite a bit of love for the Bz10 on these forums recently, so I went and picked myself up one the other week. Spent a couple of days dialing it in and it wasn't long before it started making A+ brews.

    This morning (so machine is about 10 days old), it was ~10sec into a shot when I head a 'pop', and water started spitting over the top of the PF. I've tried a couple more times since and same thing - builds pressure, bit of extraction before a small explosion and coffee & water starts flying everywhere. This even happens with a blind basket.

    Any clues as to what might be happening? Some initial thoughts:
    1) I had to take the showerscreen off to take a picture of it yesterday (small dent in it on delivery, so making a warranty claim) - perhaps I didn't replace it correctly?
    2) The Bezzerra's are known to be factory set to a high pressure - reducing might help?
    3) The gasket can't be faulty already can it......


    Please send help...I miss making coffees already

  2. #2
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665
    Back to supplier. They need to get it right.
    Dimal likes this.

  3. #3
    Site Sponsor Casa Espresso's Avatar
    Join Date
    Dec 2008
    Location
    Australia
    Posts
    763
    Hi,

    First port of call is back to your seller.

    It sounds like an issue with the seal which may have been damaged with removal and reinserting the shower screen. It may or may not be a manufacturing issue..

    Without looking at the machine no one will be able to give you an accurate diagnosis.

    If you are in Melbourne feel free to get in contact with us

    cheers

    Antony
    Casa Espresso
    (03) 9530 8992
    Dimal likes this.

  4. #4
    Junior Member
    Join Date
    Jun 2014
    Posts
    26
    Quote Originally Posted by Casa Espresso View Post
    Hi,

    First port of call is back to your seller.

    It sounds like an issue with the seal which may have been damaged with removal and reinserting the shower screen. It may or may not be a manufacturing issue..

    Without looking at the machine no one will be able to give you an accurate diagnosis.

    If you are in Melbourne feel free to get in contact with us

    cheers

    Antony
    Casa Espresso
    (03) 9530 8992
    Thank you for the suggestions Anthony. Unfortunately I'm in Sydney. May have to lug it to the nearest technician, but its a PITA I'm hoping it doesn't come to.

    If it were seal related (which makes sense), would over-tightening the screw or maybe a slight misalignment of the dispersion disc be a likely cause? They're the only things I would think I may have done wrong. I didn't drop or bang any of the parts, and I've done the same thing many times before on my Silvia with no issues

  5. #5
    Site Sponsor Casa Espresso's Avatar
    Join Date
    Dec 2008
    Location
    Australia
    Posts
    763
    Quote Originally Posted by Talk_Coffee View Post
    Back to supplier. They need to get it right.
    Unlikely to be a supplier issue I would think when the machine was working perfectly until the user removed and reinserted the shower screen
    TC likes this.

  6. #6
    Site Sponsor Casa Espresso's Avatar
    Join Date
    Dec 2008
    Location
    Australia
    Posts
    763
    Quote Originally Posted by coffeehoon View Post
    Thank you for the suggestions Anthony. Unfortunately I'm in Sydney. May have to lug it to the nearest technician, but its a PITA I'm hoping it doesn't come to.

    If it were seal related (which makes sense), would over-tightening the screw or maybe a slight misalignment of the dispersion disc be a likely cause? They're the only things I would think I may have done wrong. I didn't drop or bang any of the parts, and I've done the same thing many times before on my Silvia with no issues
    Without seeing the machine it makes sense that it as an issue with the screen/seal alignment. Particularly as it seemed to be working well until removal/re fitting of the screen.

    Maybe try removal and re fitting after that it needs a tech If the problem continues

  7. #7
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665
    Quote Originally Posted by Casa Espresso View Post
    Unlikely to be a supplier issue I would think when the machine was working perfectly until the user removed and reinserted the shower screen
    I may have missed that bit!
    Casa Espresso likes this.

  8. #8
    Junior Member
    Join Date
    Jun 2014
    Posts
    26
    Thanks for the help fellas. I opened up the grouphead and it looked like a seal problem as there were some grinds up behind it. A quick shot pull looks like its okay again - fingers crossed it holds up. I was fairly delicate in removing the showerscreen and don't remember touching the the seal at all, so the two incidents may have been coincidental. Maybe, maybe not. I also pulled the handle a little further to the right than before to ensure a good seal. Does that have any contraindications in the long run?
    Dimal likes this.

  9. #9
    kbc
    kbc is offline
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,960
    I'm glad you got that sorted out Mr Hoon. Enjoy that machine.

  10. #10
    Junior Member
    Join Date
    Jun 2014
    Posts
    26
    Unfortunately after a few coffees the problem has returned. I'll get a new gasket installed

  11. #11
    kbc
    kbc is offline
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,960
    Teething problems are painful when you get a new machine. Where did you buy this one from? It should be a very easy fix and the seller should be able to help. My advice is to call them.
    Cheers, Paul

  12. #12
    Junior Member
    Join Date
    Jun 2014
    Posts
    26
    The company put me onto the distributors who have been very helpful. They sent a complimentary gasket with the showerscreen I warrantied. Night and day difference in fit between the new one and the old one, so hopefully this is resolved. I had another thought though - the problem was set off both times using a Synesso basket i had previously. Not sure if it was just coincidence, but can a seal be dislodged using an ill-fitting basket?
    Casa Espresso and kbc like this.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •