Results 1 to 4 of 4

Thread: Nuova Simonelli Musica shutdown

  1. #1
    Junior Member
    Join Date
    Aug 2010
    Posts
    5

    Nuova Simonelli Musica shutdown

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    G'day all,

    I've picked up a NS Musica lux second hand and just had a question about shutting it down. I've trolled the forums and looked through the manuals online. The previous owner suggested turning the machine off at the wall and leaving the steam lever open to bleed any pressure out of the system and empty the heat exchanger? Anyone else doing this? Also the hot water function is super slow - few drips - certainly not that practical to make a cuppa. Could be a HW solenoid perhaps?

    Cheers

  2. #2
    Senior Member Jackster's Avatar
    Join Date
    Nov 2017
    Location
    Maddington, Perth. Wa
    Posts
    861
    My musica has a intermittent solenoid. Sometimes hot water, sometimes no water but the pump running. It is the solenoid, but havent got around to fitting the new one yet.
    The hot water is from the hx curcuit, so if you get grouphead water correctly, id suggest the solenoid is your problem. (It may just need a strip and clean out. )
    Also, my machine has a different to factory solenoid fitted, so it has had the issue before also.
    For now, i just take hot water from the brew head.
    If ordering from italy, get the gicleurs also (if not already fitted ), and pop your covers off. It may need a few stop leaks- a element gasket and thread sealer.

    I just turn machine off at the wall. It has a antivac valve fitted, so no issues there.
    I suggest a good descale of inside the boiler. I have seen a few including mine that are a bit barnacled.....

  3. #3
    Junior Member
    Join Date
    Aug 2010
    Posts
    5
    Great thanks. I'll check out the HW solenoid - no biggie really. So just to confirm - you just turn the power off at the wall and that's it? Don't bleed steam off or anything? When turning on you need to run a bit of steam through it seems? Whats the pressure gauge indicating? Mines pretty well on 1.5 when the machine is running - when pulling a shot or using steam etc. Sorry for all the newbie questions - the manual is pretty hopeless!

  4. #4
    Senior Member Jackster's Avatar
    Join Date
    Nov 2017
    Location
    Maddington, Perth. Wa
    Posts
    861
    I seem to have a big deadband on my machine. 1.4 down to about 0.9 its ok for now but i have plans for it....

    Yep, just turn it off. All done for the day. In morning i let it warm up till i can hardly touch the portafilter, a good 20 min



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •