Results 1 to 17 of 17
Like Tree49Likes
  • 7 Post By Di_Bartoli
  • 5 Post By poloallen
  • 1 Post By Di_Bartoli
  • 13 Post By milly3
  • 4 Post By Brewster
  • 1 Post By CafeLotta
  • 3 Post By Dimal
  • 6 Post By milly3
  • 2 Post By CafeLotta
  • 1 Post By Di_Bartoli
  • 6 Post By herzog

Thread: New Bezzera Mitica Top no pressure at at group head....Helo!!

  1. #1
    Junior Member
    Join Date
    Jan 2017
    Posts
    5

    New Bezzera Mitica Top no pressure at at group head....Helo!!

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    We have had a new Bezzera Mitica Top delivered today and have set up as per instructions but have no pressure at all at the group head even with the blind portafilter. Machine has been on for over an hour, it is full of water in tank mode but still nothing. Hot water is working fine and also steam. Any ideas???

  2. #2
    Senior Member
    Join Date
    Jul 2009
    Posts
    249
    Do you get any water out of the group or pump noises when lifting the group lever? I know it's Saturday, but have you tried the vendor yet? Best not to mess around with it too much if its new/under wty

  3. #3
    Senior Member
    Join Date
    Jul 2009
    Posts
    249
    Also ensure both selectors are in tank mode, there is usually an electrical switch for the low water light behind the drip tray, and also a physical valve under the machine to select tank or plumb mode (looks like a black knob) Make sure the one under the machine is in the right setting

  4. #4
    Junior Member
    Join Date
    Jan 2017
    Posts
    5
    Thanks for the reply.

    As far as the vendor goes it was Winnings appliances as the price was a lot less than specialty stores. It did concern me a little for this exact reason buying through them but the price was too good to refuse!

    So as far as the issue goes there is no pump noise and after heated up a while a little steam comes out the group head only. There is no pump noise at all. I had a look and there seems to be no switched as suggesed, only a pressure adjustment screw under the machine.

  5. #5
    Site Sponsor Di_Bartoli's Avatar
    Join Date
    Aug 2006
    Location
    647 Botany Road, Rosebery, NSW 2018
    Posts
    929
    Milly 3;

    If the machine has not been tested by the re-seller or the importer it could be anything, you can try the follow
    - turn Off and ON the machine this machine when they are new they have a cut off divice to not to over load the pump (This is usually should be done by importer or the re-saler before is been delivery to the customer)
    -Unplug the machine from the main electrical point re plug after 10 sec, this will start the main control
    -take out the water tank and put it back could be the sensor is not recognizing there is water there or the tank is not touching the sensor

    or just give me a call I will trouble should it for you,

    Regards

    Renzo
    -
    Dimal, flynnaus, Javaphile and 4 others like this.

  6. #6
    Member
    Join Date
    Nov 2015
    Posts
    31
    What a star Renzo, thats exactly why I purchased my new Rocket from Di Bartoli - fantastic customer service and always willing to offer advice and help. Good on you Renzo.

  7. #7
    Junior Member
    Join Date
    Jan 2017
    Posts
    5
    Thanks for that Renzo,

    I have tried all as per above still with no success. How can I contact you, at the store?

    Regards,
    Nathan

  8. #8
    Site Sponsor Di_Bartoli's Avatar
    Join Date
    Aug 2006
    Location
    647 Botany Road, Rosebery, NSW 2018
    Posts
    929
    Nathan; any luck let me know who do you go

    Regards
    CafeLotta likes this.

  9. #9
    Junior Member
    Join Date
    Jan 2017
    Posts
    5
    No Renzo,

    Tried all that you said with still no luck. Feeling very disappointed.

    To anyone taking interest in this post I would like to let everyone know that I didn't even purchase off Di Bartoli, Yet Renzo is offering his help and has talked to me on the phone to try and help. This sort of customer service is very rare and is much appreciated.
    arcachon, Brewster, Dimal and 10 others like this.

  10. #10
    Senior Member Brewster's Avatar
    Join Date
    Jun 2008
    Location
    Maitland, NSW.
    Posts
    187
    Hi Milly3
    I understand why you would have been tempted by a "price too good to be true". Who wouldn't be , we all love a bargain, that's just human nature.
    You are now experiencing the thing that's very hard to put a price on, top notch customer service. Renzo has offered his help at a very busy time of the year for him. Having dealt with him for over 4 years now, it doesn't surprise me at all.
    I have posted this before and I will repeat it again now, this level of service from Renzo and Ofra at Di Bartoli, is just one more reason I am happy to make the 5 hr return trip to their store when I'm in the market for new gear or taking my machine in for a service.
    I hope you get this issue sorted soon.
    Cheers
    Mal
    Dimal, Di_Bartoli, HorseFD and 1 others like this.

  11. #11
    Senior Member CafeLotta's Avatar
    Join Date
    Jun 2012
    Location
    Melbourne, Vic, Aust.
    Posts
    987
    may or may not be of use.............Troubleshooting - Fine Coffee Company
    Dimal likes this.

  12. #12
    Mal Dimal's Avatar
    Join Date
    Oct 2004
    Location
    Warwick, QLD
    Posts
    16,613

    Quote Originally Posted by Di_Bartoli View Post
    just give me a call I will trouble should it for you,

    Regards

    Renzo
    You guys are champions...

    Mal.
    Brewster, Di_Bartoli and 338 like this.

  13. #13
    Junior Member
    Join Date
    Jan 2017
    Posts
    5
    Issue sorted, I got a call from the Barazi today and we worked through a few ideas and found the fault to be a wire was disconnected on the switch that activates the pump. All back together and enjoying a great coffee....

    Thanks everyone for your help and also Renzo from Di Bartoli.
    Brewster, Javaphile, Yelta and 3 others like this.

  14. #14
    Senior Member CafeLotta's Avatar
    Join Date
    Jun 2012
    Location
    Melbourne, Vic, Aust.
    Posts
    987
    Quote Originally Posted by milly3 View Post
    Issue sorted, I got a call from the Barazi today and we worked through a few ideas and found the fault to be a wire was disconnected on the switch that activates the pump. All back together and enjoying a great coffee....

    Thanks everyone for your help and also Renzo from Di Bartoli.
    Yeh!! It can happen to the best of them. I had heard previously that Barazi (Australian Bezzera distributor), support their product really well. Good to see this in action. Top Stuff!

    Time to sit back and enjoy a bloody good machine!
    Last edited by CafeLotta; 2nd July 2018 at 04:31 PM.
    HorseFD and milly3 like this.

  15. #15
    Site Sponsor Di_Bartoli's Avatar
    Join Date
    Aug 2006
    Location
    647 Botany Road, Rosebery, NSW 2018
    Posts
    929
    Nathan; that's great enjoy your coffee now

    Regards
    Renzo
    milly3 likes this.

  16. #16
    Senior Member
    Join Date
    Dec 2009
    Location
    SYD
    Posts
    541
    Quote Originally Posted by milly3 View Post
    Issue sorted, I got a call from the Barazi today and we worked through a few ideas and found the fault to be a wire was disconnected on the switch that activates the pump. All back together and enjoying a great coffee....

    Thanks everyone for your help and also Renzo from Di Bartoli.
    For some good karma, buy a couple of bags of beans off DiBartoli. I reckon they’ve earned it by the sounds.

    I can recommend their Colombian single origin. The house blend is also a cracker.

  17. #17
    Senior Member Yelta's Avatar
    Join Date
    Jun 2009
    Location
    Moonta SA.
    Posts
    6,725
    Great outcome Nathan, the benefits of belonging to Coffee Snobs.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •