Results 1 to 4 of 4

Thread: Nuova Simonelli Musica - Water level sensor not working

  1. #1
    Junior Member
    Join Date
    Jan 2016
    Posts
    2

    Question Nuova Simonelli Musica - Water level sensor not working

    Hello All,

    Is there anyway that I can fix this myself as I am a very handy person.

    The water level sensor isn't working, it doesn't activate the low water level warning light even when water is at its lowest level, I noticed this when the pump becomes really loud when it tried to suck water from empty tank. I can see that there is a magnet in the water tank itself and it is moving freely, that mechanism is working fine. How do I fix this issue? And in addition, it seems that the volumetric isn't working too.... it just dispenses unlimited amount of water through the portafilter no matter what volumetric button I press.....

  2. #2
    Member Lyrebird's Avatar
    Join Date
    Jun 2018
    Posts
    91
    The switch (probably a reed switch) is called out as item 2 on page 75 of the Manual

  3. #3
    Senior Member
    Join Date
    Nov 2017
    Location
    Maddington, Perth. Wa
    Posts
    408
    Mine doesn't work either. I haven't tried to fix it yet though. I just check the water level more often

  4. #4
    Junior Member
    Join Date
    Jan 2016
    Posts
    2
    check this out:
    https://www.coffeeparts.com.au/parts...uova-simonelli

    I wonder what parts we need

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •