Results 1 to 5 of 5
Like Tree1Likes
  • 1 Post By rednarb

Thread: BZ35 - Not refilling the boiler

  1. #1
    Junior Member
    Join Date
    Jan 2019
    Posts
    3

    BZ35 - Not refilling the boiler

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi all,

    I'm fairly new to the CS community and decided to try my hand at a heat exchanger machine after using a PID'd Silvia for many years.

    I recently purchased a second hand BZ35 which was in bad need of a descale and clean out. I spent some time disassembling the unit down and cleaning out all the components - very satisfying process :-)
    A new set of seals all round and reassembled back together now, it's time for the last few items to troubleshoot.

    I've been trying to find the cause of a problem, where it doesn't seem to want to refill the boiler.

    Starting with a full tank (manually filling up through the Antivac valve), I turn on the machine and the heater turns on and comes up to pressure/temp. It seems to behave normally at this point. I can pull shots without any faults, and the pump and heater seem to work as expected.

    However, if I use the hot water tap (pulling water from the boiler compared to the heat exchanger) once I reach the lower water level limit, the 5 front lights (I have the volumetric model with rotary pump) start to flash and the heater turns off.

    I would have expected at this point the pump to kick in and start refilling the boiler?

    Occasionally, when I turn it on from cold, the pump starts and fills the boiler, but I had an earlier issue where it just kept pumping and flowing then out of the Antivac valve (which I then cleaned out and it seemed to fix the sticky value). But now it just doesn't seem to want to even try refilling the boiler anymore. I can assume that the level problem is working as that's what seems to trigger the controller to flash the 5 button lights when it gets too low. The motor and pump function fine for the group head output.

    I have it connected to a small water tank as opposed to plumbed in at the moment. Do you think it needs water pressure? I don't have the right fittings right now to connect it directly, but I can go buy some if it would be recommended. I have noticed however many people on this forum using such a machine with a tank.

    I'm hoping that some people here might have had some similar experience in the past.

    Thanks in advance for any advice..
    Dave

  2. #2
    Junior Member
    Join Date
    Nov 2018
    Posts
    6
    Hi Dave,
    I’m certainly no expert with the BZ35, however, I had similar issues with my BZ99. If you search posts with my username, you’ll see the thread, got some great advice from the community here. Obviously a different machine, but is sounds like possible the same root cause - issues with the boiler solenoid valve. Mine started played up after a full service also, some gunk got stuck in the solenoid cause it to remain open so the boiler would overflow. Someone with a better knowledge of your machine may be able to add to the discussion.

    All the best with it,
    Esendee

  3. #3
    Junior Member
    Join Date
    Jan 2019
    Posts
    3
    Thanks Esendee.

    I'm thinking that it might be worth a look at stripping out the solenoid and making sure it's clean.
    In other attempts, I manually overrode the Giemme controller and wired the solenoid and pump directly and managed to fill the boiler manually via the pump but still can't seem to get it to work automatically via the Giemme controller, maybe that's pointing to an issue with the controller?
    Does anyone know the logic of the Giemme controller for these machines? I.e. under what condition causes the pump to refill the boiler. Is it once it goes below the low level sensor?
    Because all that happens when I disconnect the low level sensor is all 5 of the volumetric lights flash ( and at the same time the heater cuts off - this later cutoff is what I would expect to happen to save the heating element from boiling dry).

    Thanks again to any support from the community, I hope that with more experience I might also be able to help others with the lessons I lean through this process.

  4. #4
    Mal Dimal's Avatar
    Join Date
    Oct 2004
    Location
    Warwick, QLD
    Posts
    17,198
    G'day Dave...

    The Boiler Fill Controllers on these are pretty simple devices and if faulty, are generally easy enough to repair if you have reasonable enough desoldering/soldering skills. Usually it is the PCB mounted Transformer that tosses in the towel and equivalent replacements can be obtained for reasonably little cost from Radio Spares or Element 14, for example.

    If you do a search for info related to this exercise, do a search through the forum and you should find what you need...

    Mal.

  5. #5
    Junior Member
    Join Date
    Jan 2019
    Posts
    3
    Thanks Mal,
    I'll dig into the forum about controller issues/repairs. I'm relatively handy with soldering/desoldering, so it's worth a shot to try and fault find the controller if it has an issue. Would be great not to have to buy a new one.
    Thanks for the tip.
    Cheers, Dave
    Dimal likes this.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •