Announcement

Collapse
No announcement yet.

Whats wrong with my beans ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Whats wrong with my beans ?

    Hi All, long time drinker first time poster. i have an issue with my beans.
    firstly i have a Sunbeam 6910 and 4800. the first lot of beans i ran through were vitoria that i got with the machine, they ground really nice and i got a nice strong coffee with a nice creme.
    now ive bought some beans from a coffee shop in chadstone in melbourne and when i grind them in the finest grind they come out like tea leaves and the brew is watery and week. HELP i need my coffee.
    is it the bean like i think it is? any help is appreciated.

    Cheers

    Josh

  • #2
    Re: Whats wrong with my beans ?

    The beans are probably stale.

    If there is no "Roasted On" date on the bag you have no idea how old they are.

    Youre in Melbourne; surrounded by freshly roasted coffee.

    Try Veneziano for a start; theyll be fresh.

    Comment


    • #3
      Re: Whats wrong with my beans ?

      Originally posted by 213D30273031363425263C362038550 link=1262900608/0#0 date=1262900608
      when i grind them in the finest grind they come out like tea leaves
      This shouldnt happen, sounds like its grinding way too course, did it grind the Vittoria beans finer, has anything been changed on the grinder?

      Comment


      • #4
        Re: Whats wrong with my beans ?

        Originally posted by 746865726564636170736963756D000 link=1262900608/0#0 date=1262900608
        Hi All, long time drinker first time poster. i have an issue with my beans.
        firstly i have a Sunbeam 6910 and 4800. the first lot of beans i ran through were vitoria that i got with the machine, they ground really nice and i got a nice strong coffee with a nice creme.
        now ive bought some beans from a coffee shop in chadstone in melbourne and when i grind them in the finest grind they come out like tea leaves and the brew is watery and week. HELP i need my coffee.
        is it the bean like i think it is? any help is appreciated.

        Cheers

        Josh

        Welcome...

        1: do some reading on the Em6910 and the EM0480... Use the CS search function... http://coffeesnobs.com.au/YaBB.pl?num=1257241858

        2: With out knowing your basket set-up and how your tamping / dosing as well as the REAL quality of ya beans... Even the best advice could be well off the mark..

        We all make assumptions, but with out a solid base line... It is all conjecture and may well lead to even more frustration...

        Its like asking... Can I drive to Darwin ?

        Well without knowing a lot more... A simple YES could be both correct; BUT misleading..

        Do some research on CoffeeSnobs (search)...

        Doubt if there anything that has not been asked previously... Dozens of pages and help provided almost every day... And most of it is a repeat of what was said the day before..

        Enjoy the ride... Coffee is only great when 2 + 2 = 5



        Comment


        • #5
          Re: Whats wrong with my beans ?

          Even old stale beans shouldnt come out looking like "tea leaves". Have you tried adjusting the grinder to grind finer?

          Comment


          • #6
            Re: Whats wrong with my beans ?

            Originally posted by 2B3E252A2A3F38293E4C0 link=1262900608/4#4 date=1262913901
            Even old stale beans shouldnt come out looking like "tea leaves".  Have you tried adjusting the grinder to grind finer?
            He did state that (when i grind them in the finest grind they come out like tea leaves) I agree sounds very course.

            Comment


            • #7
              Re: Whats wrong with my beans ?

              Hey thanks for your comments, nothing has changed on the grinder, and i was using the finest settings on the grinder. the original vitoria beans ground up nice and fine and made a nice brew. i bought some fresh ground (200g) bag and tried them and the machine made a great coffee.
              im almost sure its the beans, will endeavour to aquire some fresh roasted beans now and experiment with the grinding . thanks again for your advise.

              Cheers Josh

              Comment


              • #8
                Re: Whats wrong with my beans ?

                Originally posted by 2B373A2D3A3B3C3E2F2C363C2A325F0 link=1262900608/0#0 date=1262900608
                i have a Sunbeam 6910 and 4800
                just checking... we all assume when you say 4800 that you really meant 0480.
                if in fact youre saying you have 2 sunbeam coffee machines, that you have a 4800 and have upgraded to a 6910, and if youre using a spice grinder, then that could be the problem, although you would then likely have had the same issue with the supermarket beans and the new fresh ones you bought.
                a 0480 grinder on its finest setting should completely choke any espresso machine, especially a 6910... unless the grinder is well worn or faulty (or has been pulled apart and not reassembled correctly)...
                Geoff

                Comment


                • #9
                  Re: Whats wrong with my beans ?

                  Originally posted by 614D4D524750141B71220 link=1262900608/7#7 date=1263000559
                  Originally posted by 2B373A2D3A3B3C3E2F2C363C2A325F0 link=1262900608/0#0 date=1262900608
                  i have a Sunbeam 6910 and 4800
                  just checking... we all assume when you say 4800 that you really meant 0480.
                  if in fact youre saying you have 2 sunbeam coffee machines, that you have a 4800 and have upgraded to a 6910, and if youre using a spice grinder, then that could be the problem, although you would then likely have had the same issue with the supermarket beans and the new fresh ones you bought.
                  a 0480 grinder on its finest setting should completely choke any espresso machine, especially a 6910... unless the grinder is well worn or faulty (or has been pulled apart and not reassembled correctly)...
                  Geoff
                  I was thinking the same.. But discretion got the better of me for a change... ;D ;D


                  Actually.. Just gave up and went to bed, while tossing up what to hit my PC with...

                  Will be interesting to find out what the real story is...


                  Comment


                  • #10
                    Re: Whats wrong with my beans ?

                    Hi all, yes you are right, its an em0480, not a 4800. and on closer inspection i have found that the burs werent fitted correctly, i have since fixed the problem and all is good. a rookie mistake.
                    thanks for your input

                    Cheers Josh

                    Comment


                    • #11
                      Re: Whats wrong with my beans ?

                      Originally posted by 5A464B5C4B4A4D4F5E5D474D5B432E0 link=1262900608/9#9 date=1263029784
                      Hi all, yes you are right, its an em0480, not a 4800. and on closer inspection i have found that the burs werent fitted correctly, i have since fixed the problem and all is good. a rookie mistake.
                      thanks for your input

                      Cheers Josh
                      Thank YOU for coming back and posting...

                      Always good to know that your up and running and what the problem was..

                      Even Mal has been known to make the odd mistake

                      Comment

                      Working...
                      X