Announcement

Collapse
No announcement yet.

Belkin WeMo Switch - So far...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Belkin WeMo Switch - So far...

    Back in September, I posted about the impending launch of the Belkin WeMo Switch - a WiFi enabled switch into which you can plug any appliance and control the "on" or "off" settings not just by WiFi, but by using an iOS device through the mobile phone network (sorry Android users...they say they're going to come up with something for you some time in the future).They've just started arriving in stores and Harvey Norman and Apple's online store currently have stock.



    This isn't a wonderfully methodically dissection of my experience, but a quick overview for those of you who may find this kind of thing useful. Like many (most?) on the forum, my machine takes a longish time to warm up adequately. As I do a lot of work with clients in town and come home at varied times, this means I can now leave a meeting and hit the "on" switch and have the machine ready to go when I get home and should also help save energy by being able to turn it off more easily if I've forgotten to switch it off before leaving home.Up until now I've used a programmable HPM 7 Day digital timer, which has been great. The WeMo can do everything it did, in terms of setting up programs (or, "Rules", in WeMo-speak) to turn it on and off in the mornings. And of course, it can do a lot more. That said, one nice feature of the timer that I'll miss was its clock, which included seconds, allowing me to time shots. But it's worth it (and I've got an old timer that I can haul out of the drawer, as a replacement).So, first thoughts:One of the nice things about the switch is that despite having lots of functionality (including IFTTT) on opening the box you see that Belkin's done everything possible to keep things dead simple. There's the switch (with 2 status lights and 2 user operate-able switches), a concise, 4 step quick start guide and an almost equally concise product guide. As someone who works with human-centred design and development of new products, this was a joy to see.


    But it wasn't all plain sailing.

    I had to go through the process of setting up the Switch a few times, before my iPhone was able to find the device consistently. A Belkin troubleshooting video references the fact that "some routers" simply don't recognise the device without going through a few install attempts. I found this vague reference a bit unsettling -- why, and how would I know that once it did recognise it, that it wouldn't randomly fail to so in the future?!. Anyway, it finally worked. I was happy. Until I ventured forth...

    Once I was out of WiFi range, I turned on the app to see if it could see the switch. It couldn't. The menu showed the switch, with a message "Not detected", below it. I followed the various troubleshooting suggestions, such as quitting the app, rebooting my iPhone, resetting the switch (requiring fresh round of setups), rebooting the router. No joy.

    I'd previously read numerous references to this problem online and hoped that this was something that was limited to people with quirkier network setups. Mine is pretty straight-forward, so I'd been optimistic that it would all be fine. To make a long story short, I found a reference to uninstalling the WeMo app from the iOS device and reinstalling (and, yet again, resetting up the device), so I did this. I'd downloaded the app a few weeks ago, to familiarise myself with it before the switch was available in stores, so this might have been the cause of the problem. Anyway, a fresh install on the iPhone did the trick and I've now got it working, both within WiFi range and remotely.

    Click image for larger version

Name:	IMG_3554.PNG
Views:	1
Size:	634.8 KB
ID:	754094

    A few other observations:

    One of the other unsettling aspects is that management of the service occurs through Belkin's own servers. I'm not technically literate in the how this works, but I suspect this was a trade-off deemed worthwhile to keep setup relatively simple.

    While the "rules" are easily set up, using a tab at the bottom of the app, I'd entered in 2 rules, then later in the day, added a further one. When I completed the third, my other 2 rules simply vanished and had to be re-entered. Weird.

    From pics online, the WeMo looked to be roughly the same size as the HPM device, but it's actually bigger. Hopefully it'll shrink as the product evolves.

    ----

    Like lots of tech products, the pain is in the setup and persistence is worth it. That seems to be the case with WeMo...so far. Getting up and running wasn't as smooth as I'd hoped, but I'm now looking forward to using it. I'll follow up with more info after I've been using it for a while, to update on whether it's been stable and how things perform. Fingers crossed, but it's now looking very, very good.
    Attached Files
    Last edited by GMG; 15 December 2012, 11:31 PM. Reason: crafting

  • #2
    So, this morning started with promise. I woke up, turned on the iPhone and the WeMo app and it saw the device in the menu.

    I decided to turn WiFi "off" to see if WeMo's remote capability would work. It looked promising, as "Coffee Machine" still showed on the menu.
    So, all good...until I clicked the coffee machine's "On" button on WeMo.
    Click image for larger version

Name:	IMG_3555.PNG
Views:	1
Size:	586.7 KB
ID:	733386
    I was returned back to the infamous, exasperating, "Not detected" screen.

    I hoped I'd be able to turn on the WiFi and WeMo would recognise the machine once more, so I could quickly turn the machine back on, before having a shower and going downstairs to have a coffee. I'd assumed this, as many posters on WeMo's excellent online support forum, https://getsatisfaction.com/belkinwemo have spoken of smooth operation while connected to WiFi, but problems once trying to connect from further afield. The achilles heel of the device (and it's greatest promise) seemed to be with spotty remote operation. Anyway, as of now, here's all I get:
    Click image for larger version

Name:	IMG_3556.PNG
Views:	1
Size:	666.4 KB
ID:	733387
    Sadly, I'm now not able to connect even through WiFi, despite closing the app and rebooting the phone (the 1st recommended troubleshooting step).

    And whereas my autonomous HPM timer simply turned on at the appointed time, the timer settings I've programmed into the "Rules" on WeMo, require it to call the mother ship (in other words, Belkin's servers). So nothing's happening.

    I really, really wanted to love this thing, but it's making it hard and I'm getting the impression that while the concept is wonderful, operationally it's really not ready for prime time.

    I've got other things to do, so will have to sit down later and have a bash at fixing this. In the interim, I intend to link this to the getsatisfaction.com forum and hopefully get some suggestions on how to (durably!) fix this.

    Comment


    • #3
      I'm interested in wemo strictly for ifttt.com use only (not interested in using a smart phone), have you done any testing with ifttt yet?

      EG the ability to tweet or txt to turn on/off. Or "turn on when sunrise", etc.

      Comment


      • #4
        Originally posted by JamesM View Post
        ...have you done any testing with ifttt yet?
        Hi James,

        No, I've not tested IFTTT yet and probably won't for a while as I don't really have immediate need for it. Just trying to get the basics sorted, at this stage.

        I did a reset of my router and then re-did the set up and now have the iOS functionality working again. I'm now crossing my fingers and hoping...

        Comment


        • #5
          Just a quick update: Since my last post, it's been working without problem - remotely, as well as within WiFi range. Another thing I appreciate about it is that the physical override on/off switch (used to activate the switch outside of of using "rules") is much more convenient and clear than the old HPM timer (which required users to toggle through a very small display using the "mode" switch).
          Following initial frustrations it's looking good.

          Comment


          • #6
            nice one. I've heard about these issues you've been having around the place. It's clearly not as user friendly or 'easy' to set up as it should be.

            I looked yesterday at the shops for one. I figured I could use it to turn my outdoor xmas lights on and off until the season is over, then maybe put it on the Giotto.

            Idea was to use ifttt.com to turn the lights on at sunset and off at sunrise through the weather triggers they have.. pretty awesome

            Comment


            • #7
              A month in, I thought I'd update on how things are going with my WeMo.

              This is something I've really, really wanted to work -- particularly as it fuses my love of tech with my love of coffee. Unfortunately, in its current state, WeMo feels more like a tinkerer's project than a polished, ready-for-prime-time product. The setup problem is one issue. Another is overall stability. In the past few days alone, I've had to do numerous resets and setups. It's maddening.

              I'll persist with it, but hopefully Belkin will be able to fix this, particularly as the promise of the device is great.

              Apologies to James, as I've not had the ability to check out IFTTT functionality!

              Comment


              • #8
                Ahh well, maybe an update will sort those issues out. I'm still tempted to grab one...

                Comment


                • #9
                  I thought I should post another update. The WeMo has now been working rock solidly for a sustained period.

                  A few months ago, there was a firmware update and I experimented with moving the WeMo device away from the coffee machine and one or both of the changes seems to have changed things for the better!

                  I suspect that the instability arose from having the WeMo placed too near the coffee machine itself. Initially I dismissed doing this as the cause, as the router is well within what would normally be considered acceptable range. All my other WiFi devices worked from that range or even 2-4 times further from the router -- but I suspect that as my Evo 2, like most machines is composed of big chunks of metal, it was interfering with the WeMo switch plugged in right next to it. I played out the plug from the Giotto as far as it would go and plugged it into the WeMo and its worked without incidence since - both when connecting within the area of the WiFi network and when using it from afar. All good. Given this, I highly recommend it!

                  Comment


                  • #10
                    Great! Just bought today. Thanks for the tips!

                    Comment


                    • #11
                      Mines been working very well for a couple of months now!! It's a great bit of kit

                      Comment


                      • #12
                        Can you make a rule... Like "standby"? Was thinking of situations where I forget to off the machine. Like off it after X hours from on? Even better (not an electrician) but if can detect usage and off it after "low" usage after X hrs.

                        Miss this feature on my BDB...

                        Comment


                        • #13
                          Open the WeMo app and go to Rules-->"+" (to add a rule)--> Turn off (or on) only.
                          You can then create times to shut it down, if you forget.

                          I've got a "turn off at 7pm" and "turn off at 11pm" rule that runs daily. If it's already off, then nothing happens, but if I've forgotten and left it on, then it shuts it down. And that means if we've got friends over and they want a coffee after 11, I can say, "hmmm. The machine's just gone to sleep" (as in "Hint: the evening is winding down - can I get your coat?" (We've got young children, so we don't stay up like we used to!)

                          Comment


                          • #14
                            WeMo is now Android compliant. I use mine with my IPhone and love it. Ditched my old timer which did work fine but this is better. Full marks............

                            Steve.

                            Android Phones Will Turn Lights Off - Smarthouse

                            Comment


                            • #15
                              I have had this unit for a few weeks now, working really well. No issues so far.
                              great device

                              Comment

                              Working...
                              X