Announcement

Collapse
No announcement yet.

First Behmor Roast

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • First Behmor Roast



    first ever roast ever on a behmor
    350 of peru on 1lb p2 B
    pulled after 12.5 mins in just on the door of sc for a lighter roast

    only problem for me is trying to see what roast level that is exactly

    8 maybe?

  • #2
    Re: First Behmor Roast

    Congrats on your maiden roast lemoo.

    Looks like C8 or 9, but it looks like a great roast from where i see.

    The Peru is a great bean to learn on.

    Trust you have plenty of beans to play with.

    Gary at G

    Comment


    • #3
      Re: First Behmor Roast

      i also had my first roast monday 9th evening with these Peru: 430G, P1,D ( extending the time to max 22.30 )and got a similar result although Bemor timed out before i heard the 2nd crack, so i wasnt sure if they were under-done.

      Anyway first taste this morning ( 2.5 days after roast) and they were fabulous!

      I also have done last night a smaller batch 350 g starting weight and got to 2nd crack and a cs9+ colour so interesting to compare the flavour of them.

      seems to me you cant really go past 350g if you want the option of a really dark roast with these beans.

      Comment


      • #4
        Re: First Behmor Roast

        hmm just noticed something interesting

        was putting a roast through P2/B on the behmor

        according to the manual it says that p2 ramps up to 100% power to about 60% of the time and then drops the power back for about 30% of time

        and for the last 10% of time ramps power back up to 100%

        does this mean that the back elements should turn back on?
        I was datalogging the temp change as well and noticed no increase in temperature before the program ended and went into the cooling cycle

        the temperature drop was accurate @ 60% of time in but just didnt seem to increase from there and just slowly coasted to lower temps all the way to the end?

        Comment


        • #5
          Re: First Behmor Roast

          I wasnt datalogging lemoo but noticed the same thing. Expected elements to come back on at the end..

          Comment


          • #6
            Re: First Behmor Roast

            hmm thats interesting
            i wonder if anyone else has had the same experience?
            or if its meant to be that way?

            Comment


            • #7
              Re: First Behmor Roast

              Im new to this roasting caper but pretty sure it is meant to be that way: i suspect there is a lower temp at which the main element re-ignites. ( maybe less than 100C as it measures by its thermistor on the outside of the oven wall.).

              The basic problem seems to be getting to second crack with 400+ grams.

              The answer is to use less beans- max 350g i reckon, plus extend the time to max available.

              All speculation by me at this stage... no doubt Andy can confirm....

              Originally posted by 545D555757380 link=1326239866/5#5 date=1326843007
              hmm thats interesting
              i wonder if anyone else has had the same experience?
              or if its meant to be that way?

              Comment


              • #8
                Re: First Behmor Roast

                thanks for the input on the topic brettly

                yeah hopefully we will hear from someone that knows for sure

                Comment

                Working...
                X