Announcement

Collapse
No announcement yet.

Space bar not working when using quick reply

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Space bar not working when using quick reply

    Ok, this started a few days ago. Happens intermittently on the forums but seems to be occurring consistently with PMs.

    When using quick reply to PMs, the space bar doesn't work at all but will work if I try and edit the PM title. The only way I can use the space bar in the reply box is to use the "Go Advanced" mode.

    Very weird.

    Any ideas???

  • #2
    No such problem here nor has anybody else mentioned it as an issue either privately or publicly that I know of.


    Java "Wants a space bar" phile
    Toys! I must have new toys!!!

    Comment


    • #3
      What browser / device / operating system are you using? Might at least give people a chance.

      Comment


      • #4
        Originally posted by Barry O'Speedwagon View Post
        What browser / device / operating system are you using? Might at least give people a chance.
        haha_yeah_fair_call

        Windows_8,_google_chrome.____As_you_can_probably_t ell_space_bar_isn't_working

        Comment


        • #5
          Have you tried another browser....just to try to isolate the cause? I assume that you haven't accidentally changed your default keyboard (e.g. from US to International English) by hitting a hot key? Though I think that sort of thing is more likely to affect symbols like quotation marks.

          If it turns out to be Chrome specific, try disabling all extensions, and then disabling hardware acceleration and see if that does this trick.
          Last edited by Barry O'Speedwagon; 5 December 2016, 04:01 AM.

          Comment


          • #6
            I've had this issue. Couldn't be bothered raising it though, as I think it might be a Chrome bug (I have experimental features turned on) interacting with a bug in the forum platform. I'm on Mac, so it's not OS specific, but we do have Chrome in common (I'm on the current major release).

            Comment


            • #7
              I've had the issue 2-3 months. As you say, it's intermittent. Happens in DMs too.

              Comment


              • #8
                Do you have any other programs running in the background which may be interfering?

                Comment


                • #9
                  No only got chrome.

                  As you can see it's now working and I haven't changed anything, weird.

                  Comment


                  • #10
                    I've noticed something similar in the past although I can't remember if it was in Chrome or Firefox. When adding a reply I could add spaces in the middle of sentences but not at the end. Very weird.

                    Comment


                    • #11
                      Originally posted by saeco_user View Post
                      I've noticed something similar in the past although I can't remember if it was in Chrome or Firefox. When adding a reply I could add spaces in the middle of sentences but not at the end. Very weird.
                      In my tests just now, the issue is 'reply with quote'. When writing a 'PM/DM' it automatically does the reply with quote function which is why it always happens there. If I copy and paste text in to a 'reply with quote' (like I did on this one) the spacebar functionality returns.

                      I can only replicate it in Chrome, doesn't happen in Safari. Chrome throws an error for XHTML ajax calls when I look up the console log:
                      "Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/."
                      The issue is in this file: ckeditor.js at 420:138

                      Comment


                      • #12
                        Originally posted by readeral View Post
                        In my tests just now, the issue is 'reply with quote'. When writing a 'PM/DM' it automatically does the reply with quote function which is why it always happens there. If I copy and paste text in to a 'reply with quote' (like I did on this one) the spacebar functionality returns.

                        I can only replicate it in Chrome, doesn't happen in Safari. Chrome throws an error for XHTML ajax calls when I look up the console log:
                        "Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/."
                        The issue is in this file: ckeditor.js at 420:138
                        Have never experienced a problem of this nature using Fire Fox.

                        Comment


                        • #13
                          Originally posted by Yelta View Post
                          Have never experienced a problem of this nature using Fire Fox.
                          Yes it appears Chrome specific.

                          Comment


                          • #14
                            Originally posted by readeral View Post
                            Yes it appears Chrome specific.
                            At least its been identified, seems not to be a major problem, more of a nuisance.

                            Comment


                            • #15
                              Ok the error I posted is unrelated - here is a quote from vBulletin support (what the forum is built on) about support for this issue:

                              "Just to manage expectations - this is almost certainly an incompatibility between new versions of Chrome and the now quite old version of CKEditor that vBulletin 4 uses as its message editor.

                              There is no development work on vB4 now, as it is not the current product. The only work being done is php compatibility, any security issues that come up, and a handful of very minor bug fixes. Development work is focused on vB5.

                              Replacing the version of CKEditor in vB4 would be a major undertaking, requiring months of developer and QA time. I'm afraid that is not likely to happen.

                              Probably the best bet for any users affected is to get them to switch to the text-only editor ('source mode) instead of the WYSIWYG. They can do this in their user settings."

                              The issue raised in question is here: https://www.vbulletin.com/forum/foru...on-reply/page2 it gets pretty hairy once the developers step into the conversation.

                              In summary - vBulletin4 uses an old version of CKEditor, which now conflicts with Chrome. The solution posited is an upgrade to vBulletin5 (unlikely for coffeesnobs) or for us Chrome users to jump into our general user settings and change our 'message editor interface' to something other than wysiwyg.

                              Another solution is to start composing your response not on the line below, but on the same line that a quote finishes. Alternatively, typing any character on the line below the quote, hitting return and begin your response proper on a new line will solve the issue too. Then just go back and delete your added character.

                              Comment

                              Working...
                              X