Announcement

Collapse
No announcement yet.

?possible Breville Ikon problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ?possible Breville Ikon problem

    Hi all,
    Long time lurker, first time poster.

    I recently bought a Breville Ikon /Sunbeam EM480 grinder and I am very happy with the standard of coffee I can get out of the machine. I am still chasing the perfect shot, but isnt everyone!

    My question is: My coffee machine drips water from the shower screen bit as it heats up when it is first switched on. It also continues to drip after I have stopped the coffee shot, and it drips when I switch over to the steaming wand. Is this an indication of a leaky valve or something or do they all do this? Should I return the machine in case it is going to get worse?
    thanks for your help.


  • #2
    Re: ?possible Breville Ikon problem

    GDay marg3106

    I have an Ikon & it drips (a few drops) a little, but not enough to be really concerned about.

    If youre really worried, exchange it for another & see if the leaking is the same!  If it is, it just maybe a quirk that the Ikon has!  8-)

    Andrew

    Comment


    • #3
      Re: ?possible Breville Ikon problem

      Thanks. It drips about the speed of a medium dripping tap, sort of almost a continuous flow.
      The only dripping I care about is after I have made the coffee, because I will never get a tidy dry puck to bash out.

      Comment


      • #4
        Re: ?possible Breville Ikon problem

        Marg,
        ive had the Ikon and EM480 for a whole 2 days now. I havent noticed a drip but will check tomorrow. I do have washy pucks though. Im using an unpressurised basket from a Breville Bar Italia. Even with the grind choking the pump to a near stall the puck was still mushy. I wonder if its the shape of the shower screen (concave) causing this. Hopefully somebody else can shed some light on this.


        Dave

        Comment


        • #5
          Re: ?possible Breville Ikon problem

          Hi,
          no dripping here on my ikon, so I can´t help there.
          But I noticed, that if I leave the portafilter in for say 2 minutes after the pull the puck is considerably less mushy. Better is even to let the portafilter attached and then foam your milk for your cappuccino and bash the puck out afterwards the puck gets dry and stable. Oh, I should mention I use the Krups filter, not the original.

          Comment


          • #6
            Re: ?possible Breville Ikon problem

            I havent noticed a drip from mine, but when I was researching them I did read comments about some other people mentioning this on the net. Occasionally I get a drip from the steam wand but I kinda expect that with the build up. But nothing from the shower screen ,actually I tell a lie, after the shot is poured sometimes it drips but is normally over in a few seconds (not constantly dripping) but my other machine did that too. As for a dry puck, I never clean up strait away and dont bang it until after Ive had my coffee. By then its dry enough to bang, but yeah if I bang it strait away (making multiple cups for visitors) its a sloppy mess.

            Comment


            • #7
              Re: ?possible Breville Ikon problem

              my steam wand drips slowly soon after the machine is turned on. Havent noticed anything much from the shower screen but will keep an eye on it.

              Comment


              • #8
                Re: ?possible Breville Ikon problem

                I took the Ikon back and got another one. This one does not drip anywhere near as much, so I think I did the right thing. Now for the Krups basket, a good tamper and I will be set! The coffee is great - I had a coffee from a coffee chain recently as a reference point and was really suprised at how bad it was in comparison.

                I get frustrated with the way the Ikon seems to run out of steam when doing the milk - the milk takes ages. I am still trying to get the milk right and not watery. I get the texture spot on, really good microfoam, but it always ends up a bit watery and not sweet. Time to browse the milk section for tips!!


                Comment


                • #9
                  Re: ?possible Breville Ikon problem

                  Marg,
                  My Ikon does drip from the shower screen when steaming milk. However more annoying is the dripping from the wand when heating up (leaks over the bench if not positioned right). Just recently it also drips from the wand when doing the shot. Yes- the wand is turned off firm. Seems what ever the problem its getting worse.
                  Did you contact Breville before taking it back(if so-what did they say) or just return it to the store.

                  Dave

                  Comment


                  • #10
                    Re: ?possible Breville Ikon problem

                    Might be that "turned off firm" is the problem here. I guess this is a pin valve which doesn´t really like to be screwed in firmly and suffers from it with the described consequences - leaking through the wand.
                    I use to turn the knob shut very lightly and find it sufficient, without a described leaking problem after apr. 4 months of use and roughly 6-8kg of espresso.
                    I, too notice slight leaking from the showerscreen though when bleeding the wand, doesn´t really bother me since I want the shower screen to be clean of muck anyway and use to wash it by flushing water through it regularly.

                    Comment


                    • #11
                      Re: ?possible Breville Ikon problem

                      when i say firm i guess i mean light. Definately not tight(two fingers until it just seats). I deliberatley refrained from going any tighter- noting the wand dribbled from day one. And to see the leakage rate increasing over only a few weeks indicates a definite failure within the unit.

                      Comment


                      • #12
                        Re: ?possible Breville Ikon problem

                        Dave,

                        I just took it back to the store (Target) and they swapped it for a new one.

                        Comment

                        Working...
                        X