Announcement

Collapse
No announcement yet.

Via Venezia PROBLEM - Pump engages as soon as turned on

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Via Venezia PROBLEM - Pump engages as soon as turned on

    Using older model of the machine, used for 2 years so far with no problems.


    PROBLEM:
    When I turn it on to warm up, the pump engages and water come from the brew head right away. Only way to stop the pump is to engage the steam button.
    I have tried turning the steam wand on and off (tightly off) and this isnt having any effect. Have read the manual and found no mention of troubleshooting this.

    I saw that as this link: http://www.fixya.com/support/t584911..._button_turned ....the person got help from Starbucks customer support to adjust a "cam" under the hood. Im not sure what a "cam" is, or looks like? Ive taken the hood off, does anyone know which part exactly I should be adjusting? Or any other troubleshooting ideas? Or any ideas where I could get some help online - short of taking it to a Saeco service centre (its an old / cheap machine, repair bill would likely be similar to picking up another machine on ebay).

    Thanks for any help, very frustrated (and irritable from lack of coffee!).

  • #2
    Re: Via Venezia PROBLEM - Pump engages as soon as turned on

    Hi there jesuislepop,

    A website called something like partsguru (google it) lists a number of parts diagrams including Saecos. The files are downloable - pdf from memory. The last time I looked some machine models had numerous model changes as the manufacturer changed designs so you might need to start with the newest and work back in time.

    The starbucks version might be a little different too.

    A cam is an eccentric or off-round wheel. A non-circular circle. It will be mounted on a shaft or spindle. As it rotates (maybe as a knob turns the spindle) the distance from cam centre  to outside edge changes relative to a fixed point. This then might flip a microswitch that operates a pump or valve. Depending on the quality of the diagram it might appear circular but you should be able to recognize the location from the diagram.

    Anyway the Via Venezia parts list will possibly be in Italian.
    Cam in Italian is [edit]cammo - oops should be camma[/edit] or eccentrico (thats what Fiat calls them).

    Comment


    • #3
      Re: Via Venezia PROBLEM - Pump engages as soon as turned on

      A cam is just a "sticky outy bit" on a shaft, so that when you turn the shaft the cam will hit something on the way around...

      From the sounds of that link, there is a cam on the steam knob shaft which activates a switch when its fully closed - but it sounds like you have a steam switch, not a steam knob?

      Also, it looks like that poster meant to say water is coming out the steam wand, not the brew head, so your issue could be different... sorry that may not be helpful!

      Comment


      • #4
        Re: Via Venezia PROBLEM - Pump engages as soon as turned on

        @dabbler Thanks so much, looking into this now!

        @iaindb no the problem is as described - water is coming from the brew head involuntarily until I hit the steam switch, then it stops. The steam dial (it has switch and dial) seems to work fine - but based on other diagnostics I read its related to the Cam of the steam wands dial (under the hood). Thanks for your input though!

        Great to get some fast responses, Ill write back when I work it out, if anyone has further ideas please help me out!

        Comment


        • #5
          Re: Via Venezia PROBLEM - Pump engages as soon as turned on

          Got it!

          Ok, found this pic on partsguru (thanks again dabbler) that clearly shows which part is the cam & yes thats a little allen key screw in it.


          Looking at the diagram, just under the letter C you can see theres a flexible piece of metal pushing up against the cam. This is an autoswitch. When depressed, it makes the brew head pour (same as when you are pulling a shot). My cam had gone out of place, so that this autoswitch was constantly depressed (poor guy).

          The fix was to undo the allen key and readjust the dial <---> cam relationship so that when done up (ie when no water coming from steam wand) the autoswitch wasnt depressed. When the steam wand dial is turned it still depresses the autoswitch, but it has no effect because youre in steam mode (see above where I said the steam switch was causing it to stop). Make sure you use insulated tools and preferably adjust, then switch on to check, switch off, adjust etc - 240V in there, BE CAREFUL.

          Anyhow, problem fixed, hopefully when someone has the same problem in the future they find this and get through it also.

          Comment


          • #6
            Re: Via Venezia PROBLEM - Pump engages as soon as turned on

            excellent - great follow up! The only thing I would suggest is upload that photo here in case links change in the future. It could probably be a bit smaller and still be readable.

            Comment


            • #7
              Re: Via Venezia PROBLEM - Pump engages as soon as turned on

              Good idea! Pic attached, hope this helps someone else down the track...



              Comment

              Working...
              X