No announcement yet.

EM5900 - Can this be easily repaired?

  • Filter
  • Time
  • Show
Clear All
new posts

  • EM5900 - Can this be easily repaired?

    Hi all,

    I've been running a Sunbeam EM5900 for a bit over 2 years. I went make a coffee and when I pressed the coffee button, the water button lit up and water came from the wand. I tried a couple more times and the same problem persists.

    Does anyone know if this is a simple repair? I don't want to take it somewhere and pay a service fee to find out it is not cost effective to repair. Deciding whether to try and get it repaired or just cut my losses and buy another machine.

    Thanks, Jase.

  • #2
    Bueller?..... Bueller?...... Bueller?.....


    • #3
      I think I meant to reply to this ages ago but forgot, sorry mate. Sounds like it might just be a dodgy switch board, best case scenario. Would be worth opening it up and checking if there's any corrosion or damage to the switch contacts or tracks.
      What happens when you press the other buttons? Do they work as normal? When you press the hot water button, does hot water come out or does it start the coffee extraction or do some other thing?

      I'd say it's either the switches/board or the main control board at fault.Check switches and the board first and see what you find.


      • #4
        Thanks noidle22, I'll open it up and see what I can find. I'll also test the other buttons.



        • #5
          Well I fired it up and tried again. Pressed the coffee button first... hot water. So then I pressed the steam button... steam worked. Pressed the coffee button again... it works now!

          Not sure what that means but it's working as per normal now. I might hold off on opening it up until the fault occurs again.

          Thanks for the suggestion noidle, can't believe I didn't think to test the other buttons