Announcement

Collapse
No announcement yet.

Gaggia Evolution short circuit - washed the elements

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Gaggia Evolution short circuit - washed the elements

    Hi all,

    I have a Gaggia Evolution. I pulled it apart, cleaned it, put it back together and now it trips the circuit breaker.

    If I do not connect the heating elements it does not trip the circuit breaker. If I do not connect the thermostat on the side, it also does not trip the circuit breaker.

    I am pretty sure I got the wiring back correctly. I suspect that the problem is that I submerged the heating elements in water, in an ultrasound when I cleaned it. Although the resistance in the heating coils is around 21 ohm and the resistance between the heating coil terminals and the boiler case is infinite.

    Any suggestions on what to do?

    Buy a Silvia?

    Thanks, David.

  • #2
    Sportssedanman,
    First thing is either leave your machine disassembled to dry out or use a compressor to blow away the moisture and give it day or so and retry again to confirm whether moisture was to blame for the short,and tackle the further necessary action.
    Cheers
    Mick

    Comment


    • #3
      Fixed

      Originally posted by mulquemi View Post
      Sportssedanman,
      First thing is either leave your machine disassembled to dry out or use a compressor to blow away the moisture and give it day or so and retry again to confirm whether moisture was to blame for the short,and tackle the further necessary action.
      Cheers
      Mick
      Thanks Mick, it is now fixed.

      I plugged it in with the earth lead to the boiler case disconnected. I switched it on and then tested the voltage between the earth wire and the case and it was less than one volt - so no major short circuit. I used an IR temperature probe to check the temperature of the coils as they heated up. As they heated up some steam came out of the coils, around the porcelain insulators at the top. Now it works fine (with the earth lead re-connected). Seems that heating the coils was the best way to get rid of the moisture.

      Note that I was EXTREMELY careful to not touch the boiler case when the earth lead was disconnected.

      Comment


      • #4
        Gaggia Evolution issue

        Sportssedanman,
        Good to know your coffee is flowing correctly again,I'm interested in knowing how your cleaning with the ultrosonic went,I have one at my work that could accept the complete boiler like you must have used.
        Other then the moisture problem,did it manage to clear away the internals for the boiler better then "elbow grease"?
        I intend to try the ultrosonic cleaner as well however,I will finish it off with a half hour oven warm on low heat to remove all the moisture before reinstalling.
        Cheers
        Mick
        Originally posted by Sportssedanman View Post
        Thanks Mick, it is now fixed.

        I plugged it in with the earth lead to the boiler case disconnected. I switched it on and then tested the voltage between the earth wire and the case and it was less than one volt - so no major short circuit. I used an IR temperature probe to check the temperature of the coils as they heated up. As they heated up some steam came out of the coils, around the porcelain insulators at the top. Now it works fine (with the earth lead re-connected). Seems that heating the coils was the best way to get rid of the moisture.

        Note that I was EXTREMELY careful to not touch the boiler case when the earth lead was disconnected.

        Comment


        • #5
          I used to have an evolution till i stepped up to an europicolla...

          And the most annoying thing was getting a pf sneeze...

          And thats how i learned about 3-way solenoids...

          But i am lucky i dont need to backflush the evolution...

          May i ask you OP, do you have any tips on installing a 3-way solenoid in the evolution?

          Comment


          • #6
            3 way solenoid valve for gaggia evolution

            Dear Java Beanery,
            Sadly your evolution gaggia has no 3 way solenoid valve ,there is also no provision to fit one as the boiler mounting base is not equipped with suitable mounting points.
            When compared to all the other gaggia like Classic ,dose,etc which have solenoid operated 3 way valves.
            Cheers
            Mick,
            Good site worth checking for confirmation is gaggiausers in USA,very detailed references there.
            Originally posted by JavaBeanery View Post
            I used to have an evolution till i stepped up to an europicolla...

            And the most annoying thing was getting a pf sneeze...

            And thats how i learned about 3-way solenoids...

            But i am lucky i dont need to backflush the evolution...

            May i ask you OP, do you have any tips on installing a 3-way solenoid in the evolution?

            Comment


            • #7
              Thanks mulquemi for the info.

              1+

              Comment


              • #8
                I have since found a better way to dry out the heating elements - put the top part of the boiler, with everything removed in the oven at 120 Celsius for an hour.

                Comment


                • #9
                  How about don't immerse them? Bloody lucky to get away with drying it out, it doesn't always work

                  Comment

                  Working...
                  X