No announcement yet.

Faema Family (1st version, 80s)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Faema Family (1st version, 80s)

    Hi guys,

    this is my first post in this great forum

    Yesterday, in the basement, I found an old Faema Family coffee machine + the Grinder, this model:

    The coffee machine:
    I cleaned all the tubes, removed the calcium....and it seems that it works very good!
    At the end, I did a coffee and it was amazing :-)

    But there is a problem, I noticed that the second lamp (the steam) never switch off....... I suppose that there is a problem with the Thermostat; in fact, the hot water that came out....was very very very hot!!
    Yesterday, in order to avoid to damage the machine, I preferred to power off.

    My first question is: what is the Thermostat model/type (temperature degree) that I can use/replace?

    The Grinder:
    This machine made me crazy!!
    There is a problem with the Coffee Bean Container! It seems to be completely stuck!
    I tried to move it clockwise and anticlockwise, tried to pull up (with two pliers) from the grinder motor...but no luck, at the end I stopped myself to avoid to damage it.

    Also, I noticed that it's not possible to un-mount the grinder because the Ground coffee Container is fixed to the machine with two screws located properly under the Coffee Been Container....and if I don't remove this first, it's impossible to open the grinder!

    Any idea?
    In normal condition: is it possible to pull up/remove the coffee bean container from the machine/motor?
    How can i proceed to fix it?

    Thank you very much for any suggestions and help!!

  • #2
    Hi I just joined the forum and read your post. I see it was posted last year. I have one of these units and can confirm the 2nd lamp does not switch off. If you depress the button you will find it appears brighter. This helps heat up the boiler for more steam.
    I have one and its as strong as a tank.