Announcement

Collapse
No announcement yet.

Breville EM6910 - Repair or Buy New?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Breville EM6910 - Repair or Buy New?

    Hi all,

    Have been lurking for ages but first post.

    I have acquired an EM6910 for free, but the steam is intermittent and the coffee thermablock is LOUD!

    I'm wondering if in your opinion I'd be better off getting it repaired, or buying new? Either the same machine ($500) or something like the Breville Infuser?

    Wanting to do full manual.

    Cheers!
    Mike

  • #2
    Plenty on how to fix these.
    Recommend the full clean with the vinegar solution to get the steam going as per the manual. (And on here- Tampit has made lots of posts on this for one)
    Noisy brew thermoblock? Is it the pump making a racket? Flow test it- try for 300ml in 30sec. But probably pump has gut full of air in it.
    Clean your shower screens.

    Try that first, before throwing it out

    Comment


    • #3
      Here's one link...
      https://coffeesnobs.com.au/brewing-e...eep-clean.html

      Comment


      • #4
        Thanks Jackster, much appreciated! I'll have a play around.

        Comment


        • #5
          The link is pretty good. Covers pump priming, vinegar/citric cleaning, links to the manual etc.
          Most of all the gurus posted in that one thread.

          Only think not covered was the pump flow test. As I said, around 300ml in 30sec. Mine only does near this volume with the valve above the shower screens removed. (I think I have a issue with the airbleed valve on pump nose, leaks with little pressure, but seals with more. I think the little spring on the valve makes the water backflow around the airbleed circuit and not through the group.)

          I'd like to see your results comparing that valve installed/removed.
          You need to turn the brew on and wait for the 3 preinfusion pulsed pumps, then put the container under and start the timer.

          Comment


          • #6
            Originally posted by Jackster View Post
            The link is pretty good. Covers pump priming, vinegar/citric cleaning, links to the manual etc.
            Most of all the gurus posted in that one thread.

            Only think not covered was the pump flow test. As I said, around 300ml in 30sec. Mine only does near this volume with the valve above the shower screens removed. (I think I have a issue with the airbleed valve on pump nose, leaks with little pressure, but seals with more. I think the little spring on the valve makes the water backflow around the airbleed circuit and not through the group.)

            I'd like to see your results comparing that valve installed/removed.
            You need to turn the brew on and wait for the 3 preinfusion pulsed pumps, then put the container under and start the timer.
            I got 225 with the valve in and 270 odd with it out.

            Turning on both the hot water and steam got the steam running better but not sure if it’s perfect yet.

            I think ill I’ll do another vinegar flush.

            Comment


            • #7
              Mine was similar. About 20% less with the valve in. In my opinion 270ml is probably ok for pump flow. As you will lose a small amount of flow through the airbleed, and some through the thermoblock and piping.

              You know the steam and the hot water/brew run on seperate pumps?
              Go again on the steamer. It takes a fair bit to clear it out if it's not been done in ages.
              You are probably good for black coffee now though. After it's all rinsed through. Take some water from the group and let it cool, taste compare it to the water you put in the machine. It should be pretty similar

              Comment

              Working...
              X