Announcement

Collapse
No announcement yet.

800ES /B head gasket blown out?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Siggypony
    replied
    Hey Pretty certain it was the seal on the grouphead. After removing all of that and cleaning that area and inside the case around it, machine is back to making nice coffee again I think if it was the seal between the grouphead and the thermo block I'd expect it to continue blowing out. It does occur to me when I removed the grouphead to clean it a few days earlier I may not have tightened it back up enough. Not sure, it's secure now.

    That said, if it happens more I may remove the thermoblock to check the seals, I have an extra thermoblock and grouphead spare from another machine if I need it.

    Leave a comment:


  • Jackster
    replied
    Is it leaking from the group gasket or a boiler seal?
    Sometimes the surface above the group seal gets gunk stuck to it. Needs a scourer or similar to get it clean

    Leave a comment:


  • Siggypony
    started a topic 800ES /B head gasket blown out?

    800ES /B head gasket blown out?

    Hi,

    So I've just recently got into all of this. I got a very sad Breville 800ES/B for $10 and completely rebuilt it, replacing most of the seals etc including the group head gasket. When I got it the entire inside, thermo block and upper components all looked like a coffee explosion had gone off inside the group head. I figured they must have continued to use it with the extremely brittle and worn seal it had with its group head.

    So I was just using it and I might have tampered my grounds to much because it really wasn't flowing but then there was this wosh noise and steam started roaring out out the vents around the group head. After it lost pressure I turned it all off etc. Just opened it up and it has some grounds blown around inside like before I cleaned it.

    Is this a known thing with 800ES? I'm guessing I hadn't cleaned the rubber around the new head gasket and it just got out, or maybe I didn't tightened the screw on the group head enough and the seal wasn't tight enough between the the group head and gasket. I've checked the gasket and it's fine, maybe it's a cheapo one? It looks like silicone as oppose to rubber.

    Is this normal? I've got another 800ES in Red I am working on it had the same coffee explosion inside too when I got it.

    Can't attach image, but you get the idea.

Working...
X