Announcement

Collapse
No announcement yet.

Expobar G10 - getting more steam...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Expobar G10 - getting more steam...

    Hey all,

    I hope you will be able to help me with an upgrade I want to make to my machine. We are running at the Kelvin Grove market s Brisbane every saturday and we are very busy just about every week now.

    The slowest part of our espresso preparation is without a doubt steaming the milk.

    I have included some photos of the machine inside and out below if this will help in any way.

    My aim of modifying the machine is to get more steam power so I can steam the milk to the desired temperature faster, without losing any quality.

    I have no probs with good milk on the LM Linea at work, and I have no probs with good milk on the Expobar, only difference is it takes about twice the time.

    We are currently using a two hole tip on the steam wand. I tried a 4 hole tip, and it make the steaming of the milk faster, but I could not get a decent swirl as it felt like it had lost its oomph coming out of 4 holes.

    The machine has also been fitted with a lever instead of a tap/knob to turn the steam wand on and off. Would this be restricting the flow at all?

    The boiler is "automatic".

    Any suggestions on how to improve this situation? I feel like the answer is to use the 4 hole tip, but we need more steam power?

    Cheers




  • #2
    Re: Expobar G10 - getting more steam...

    Hi guys,

    We distribute these and I use the exact same model in our factory. I use a 4 hole steamtip and froth a 1.5L jug no probs when required. Generaly I use a 1L jug and it froths quickly.

    The model you have is a multiboiler Americana so it should keep up on the steam well.

    Maybe the steam pressure is a bit low. What is the temp on the digital display for the steam/hot water (not the group head individual boiler displays)? 120deg is about 1.2 Bar which is what mine is set at.

    Cheers, Mark

    Comment


    • #3
      Re: Expobar G10 - getting more steam...

      Interesting innards on this beastie, it looks like each group has a preheat HX and a boiler 8-)

      Comment


      • #4
        Re: Expobar G10 - getting more steam...

        Ok, the boiler goes to 120 degrees, so same as yours. Ill try the 4 hole again and see if I can get it nice. Maybe I was having a bad milk day last time...

        Does your machine has the on/off steam knobs as opposed to tap ike knobs?

        Comment


        • #5
          Re: Expobar G10 - getting more steam...

          hey there i sold one of these last year and my client had the same issue. we put a 4 hole on one side and a 2 on the other and he mixes them up depending on the milk but the 4 hole is definatly better from my experiance on them. also because this has the group boilers you should be able to wind the pressure up to 1.4-1.5 without to many issues. the safety valve is rated to 1.6 so will take the increase easily

          Comment


          • #6
            Re: Expobar G10 - getting more steam...

            Hi there,

            Yes mine has lever arms as well. If you have no heat steam arms they generally dont work as well as the nromal ones. Looks like you dont though as you have some tape around one of the arms.

            Lever taps require more maintenance as there are more waring parts than the twist knobs. The tap valve may not be opening enough. You could see if the pressure is different for each of the steam wands as this may indicate something is not right within one of the tap fittings.

            If you want more pressure you can turn the pressure stat up. 125 deg should be about 1.4 bar and as the per the previous post it should be right to 1.6 bar.

            Cheers....

            Comment


            • #7
              Re: Expobar G10 - getting more steam...

              Ok.

              So the left arm does have more power. Which means I might looks at replacing some parts on the right one as this is the only one we use.

              Ill also looking at rasing the temp up a bit.

              Will be trying the 4 hole on the right arm this weekend...see how it goes. I made a coffee on the left arm last week with the 4 hole on it and it was ok, so maybe its just the right arm thats the problem.

              Thanks for all the info so far.

              Comment


              • #8
                Re: Expobar G10 - getting more steam...

                And yes, you are right. I took the cool touch plastic out a while ago to try to rectify the problem, hence the tape...

                It made a minor noticeable improvement, but not much.

                Comment


                • #9
                  Re: Expobar G10 - getting more steam...

                  Well. I went back to the 4 hole and I think I know the problem...I just dont like the way the steam comes out. As mentioned, I have no problems on the LM at work with a 4 hole. Maybe its the angle of the holes or something, but its just way outta control on all jugs except the mammoth ones which we dont use.

                  So, I jammed a nail through the 4th hole, making it a 3 hole. It is a good compromise for speed while still being able to get a good whirlpool.

                  Hmm, so yeh. I like this machine for what it is, but give me a linea anyday...

                  We still get good results, but the linea at work is definitely better.

                  So yeh, thanks for all the replies and help. Turns out I just sucked (and every barista who used it with a smaller jug sucked) with the 4 hole.

                  Comment


                  • #10
                    Re: Expobar G10 - getting more steam...

                    If you are fine on the LM and you say you dont like the way the steam comes out have you tried changing tips.

                    Comment


                    • #11
                      Re: Expobar G10 - getting more steam...

                      Hi Xococo, Did you mod the G10 steam arm yourself? Im very keen to find out how you did. I have a G10 and would love to replace the nob with a lever. Hope you can help.

                      Regards,

                      Tim

                      Comment


                      • #12
                        Re: Expobar G10 - getting more steam...

                        Originally posted by 634F5C5A474F4271634140454B572E0 link=1257147409/9#9 date=1259232674
                        If you are fine on the LM and you say you dont like the way the steam comes out have you tried changing tips.
                        It has a different thread type to all the other tips.

                        Comment


                        • #13
                          Re: Expobar G10 - getting more steam...

                          Originally posted by 544A52494646424F59200 link=1257147409/10#10 date=1259664569
                          Hi Xococo, Did you mod the G10 steam arm yourself? Im very keen to find out how you did. I have a G10 and would love to replace the nob with a lever. Hope you can help.

                          Regards,

                          Tim
                          No, it came with the levers. Given I open the steam differently depending on the jug size at work on the LM I would reccommend keeping the knob. Maybe we couldve controlled the 4-hole on a 5-ounce jug properly if we had a knob instead of a lever?

                          Now we have to make one steam tip fit all and compromise on speed with big jugs so we can control the smaller ones properly.

                          Comment

                          Working...
                          X