Announcement

Collapse
No announcement yet.

Faema E98 Compact A1 Cleanup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Faema E98 Compact A1 Cleanup

    Hi, I have a Faema E98 Compact A1 thats been in storage for at least two years. Since Im a new member I cant include a picture or a hyperlink in this post, but if youll copy/paste the subject line to Google youll see fairly close to the top of the list a link to the 1st Line Equipment website and their picture of the machine I have.

    Prior to storing it was used about three times a week to pull a shot or two. It wasnt plumbed, the built in tank was used. The water was hard, theres a fair amount of calcium buildup on the walls of the tank and on the filter that floated in the water - which I suspect was past due for replacement but still in service.

    I used to have one just like this in the coffee bar that I worked at years ago. Nice machine. All service and maintenance on that was done by an outside company. Id like to have a go at this one myself.

    I filled the tank with water and fired it up and it came up to pressure in about eleven minutes. I attempted to flow water through the group head. Some came through but I noticed that the pump didnt engage to pull water into the boiler so I stopped the water flow. I briefly checked the water spigot and steam arm on the right, both worked although I only used each for a second or two. I didnt try the milk frothing attachment on the left.

    All this testing, while minimal, used up the small amount of water that was held in the boiler during storage. The red boiler light on the display panel came on. My memory says that that when that light comes on, I should hear the pump engage and water should be pulled from the tank and into the boiler. No such luck.

    After a short time, the machine sounded a brief alarm, and the boiler light on the display panel started flashing. I turned the machine off.

    So, thats where I am. I know how to release the side panels with the spring-loaded allen screws on the top, but I have no parts diagram to let me know what is what in that tangle of tubes and wires I see inside the machine. I think the first thing I should check is if the pump is seized up, but I dont know where the pump is.

    Any help would be greatly appreciated.

    Cheers and thanks.

  • #2
    Re: Faema E98 Compact A1 Cleanup

    Your pump will be unmistakable. Its mounted onto your motor(the biggest thing next to the boiler)and should release easily after undoing the bolts. Follow your water inlet line and itll lead you right to it.

    Comment


    • #3
      Re: Faema E98 Compact A1 Cleanup

      Hi Tom1001 and welcome

      I picked up one of these exact machines earlier this year and cleaned it up and got it working with the help of CSers. Here is the link to the thread:
      http://coffeesnobs.com.au/YaBB.pl?num=1303139144

      I have some manuals and info etc I received from a CSer, PM me your email I will forward it to you.

      you should drain the boiler, there is a drainage "tap/nut" to get rid of all old water etc.

      Maybe your pump is stuck after years of not being used, and just needs to be freed. My pump bypass had this issue.

      you can also quickly and easily remove the front and rear (and top) panels to give you a good view of things.

      I have only seen my boiler light on (ie not flash), the tank light does both.

      if you turn on the water, you should hear your pump, likewise the brew. if the pump was not working you would not be getting any water when brewing at all? Can you hear the pump at all?

      Cheers

      Comment


      • #4
        Re: Faema E98 Compact A1 Cleanup

        FlowTrue, thanks for the pointer on where the pump is.

        Artman, nice of you to offer the manuals and info. That would be great. My email is zssdlgduzu@gmail.com.

        My guess is the same as yours, that the pump is just stuck from not being used for so long.

        You suggested turning on the water to hear the pump. Pushing the water button produces nothing. I get no sounds at all from the pump.

        Thanks for your help!

        Comment


        • #5
          Re: Faema E98 Compact A1 Cleanup

          Just emailed you all the info I have.

          To my knowledge, I am pretty sure you will have to separate the pump from the motor to try and turn its shaft manually. Maybe others with more experience on rotary pumps can confirm/suggest another way to give it a kick.

          The other way if you are electronically able/qualified is to test if the pump is getting power with a multimeter when you hit the brew switch, but this is best only attempted by qualified electricians, as you could zap and kill yourself, which would not be fun!! Also, dont forget to unplug the machine from the power point when working on it.

          The electronics of this machine is under the black cover under the drip tray, housed under a clear plastic box. You could look there to see if you see anything obviously burnt out etc.

          Actually, another way to test if the pump motor is working might be take the pump off , reinstall the motor, and see if it works with no load/pump.

          Do you hear the solenoids clicking when pressing the brew/steam/water buttons?

          Cheers

          Comment


          • #6
            Re: Faema E98 Compact A1 Cleanup

            You could try giving the pump body a gentle tap with a hammer or shifter when its trying to run, sometimes that will do the trick if its just seized.

            **Err... I should read posts more thoroughly. The above only applies to rotary pumps, and if your E98 has a tank it will be a vibe pump I think.

            Comment


            • #7
              Re: Faema E98 Compact A1 Cleanup

              My E98 A1 has rotary pump, which is what I presumed his has?

              You can use it tanked or plumbed.

              Cheers

              Comment


              • #8
                Re: Faema E98 Compact A1 Cleanup

                Ah yes, Im thinking of the non-volumetric version. As you were :-[

                Comment

                Working...
                X