Announcement

Collapse
No announcement yet.

La Cimbali Junior dropping pressure

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • La Cimbali Junior dropping pressure

    Hi all,
    I just finished a complete service (including total descaling) to my recently bought Junior and I suspect something is not OK:
    When I fully open the steam wand the boiler pressure drops suddenly almost to zero!
    Is it normal with this machine or perhaps is something wrong?!
    I had before a Cimbali M27 Start and never had this kind of problems.
    Any help would be appreciated.

    Cheers

  • #2
    Does it always drop to zero or does that only happen the first time you open the steam wand after turning on? Once its dropped to zero after opening the steam arm, when it comes back up to pressure does it operate normally? If so then your anti-vac valve is either stuck or non existent.
    Are you ok with opening the case and looking inside? Have a look at the valve when it's cold and press it down. If when you press it it falls then its getting stuck and not releasing false pressure in the boiler on start up. This can happen when it gets old or after a descale as the rubber seal gets old and sticky.

    If it happens all the time - not just after start up - then I dunno!!!

    Comment


    • #3
      No it happens only when I don't use the steam wand for a long periode. And it doesn't really drop till zero but between 0,5 atm. and 0 atm..
      After opening and closing it a few times in sequence it doesn't drop lower then 0.8 atm.
      Thanks

      Comment


      • #4
        Hello valimar,

        As per James' advice, you need to replace the anti-vac valve on your machine.

        The latent pressure reading you observe may well be a partial blockage of the capillary tube to the pressure gauge- due to scale.

        Cheers

        Chris

        Comment


        • #5
          Thanks, Chris and James,

          As a matter of fact I just checked the anti-vacuum valve, above the boiler but everythink was without scale and the O ring was also OK.
          Chris, you could be right about the capillary tube because is one of the few things I didn't clean with citric acid! I 'm going to take a look at it!

          Cheers,
          Rodrigo

          Comment


          • #6
            On my machine (Faeme/Cimblali) the tube feeding the gauge is quite large in diameter (5mm or so) and clear, but scale/crud got into the gauge itself causing it to be slow responding/sticky (its orifice is only ~1mm ). I descaled it once (hooked up a rubber hose ~1m long to give it some head pressure) but after a while it started to play up again. Must give it another go and hopefully getting it going again. Otherwise its time for a new gauge.

            Cheers

            Comment

            Working...
            X