No announcement yet.

no water from GH, low pump pressure on commercial Wega. Just been descaled

  • Filter
  • Time
  • Show
Clear All
new posts

  • no water from GH, low pump pressure on commercial Wega. Just been descaled

    Hi all
    One Wega (2 group EDV./ 2 AT) cross my way and I've started fixing it. Now I'm not sure how to continue.
    The machine was not working for some time sitting, catching dust. I guess common thing in this case, when you want to put it on again, something happen.
    First problem was water pump. After some playing and descaling bought new one anyway. Water was filling boiler alright, after getting the right brewing pressure, just few drops from one GH, nothing from the other one. Low pump pressure on the gauge (2-3 max, should have show 7 guess)

    Well almost whole machine dismantled, soaked overnight into descaling solution. It was of course full of scale and stones. very badly. Both GH full of green scale few mm thick, blocking all the way trough.

    All clean, mounted together, filled with water, short circuit. Drying of element for few hours fixed the short.
    Again filled with water, right temperature and brewing pressure but still low pump pressure, no water from GH at all. Pump is pumping and slowly overfilling the boiler. Ive tried setting up the pump with the screw on the side. no change at all.

    Now im wandering if the problem can be only in GH itself, maybe some solid stuff which i missed blocking the way. Although i think I've check it out, before putting together. Ive cleaned the water filters in GH.

    I'm not sure how to check the GH solenoids valves and not sure how they work either.
    Next what I've been thinking of are the volumetric flowmeters. Same thing, not sure how to check them and how they work.
    Maybe someone could explain to me, when they supposed to be on and when they blink.

    Important might be that i did not descale the pressure gauge (i wasnt sure if i can put it into water)
    Another thing: The machine soak the water in from water can, not a wall fitting

    Any comments and help very appreciated
    Many Thanks Sima
    Last edited by sima; 23 November 2014, 11:00 PM.

  • #2
    You need to stop the boiler filling before you can solve this issue. If the inlet solenoid or manual fill valve are stuck open then you will be loosing pressure there.


    • #3
      Also, at this point you only need to make sure that water is passing through the flow meters. Whether they are working or not, water should still get to the group heads. The flow meters (if working) should blink any time water passes through them. Good luck.


      • #4
        Seems likely your flow meters are blocked,especially as you said the machine was dirty every where else.
        Flow meters are so uncomplicated and very easy to maintain,important to confirm the light gauge wire connections are intact and electrically sound.
        Usually the outlet connector becomes blocked because of the very small orifice.
        remove the three or four screws and carefully disassemble,clean and reassemble...done.
        As Perfect above said,check LED are flashing during operation and you should be good for GH flow.


        • #5
          Thank you guys very much for suggestions. In the mean time i had dismantled and double checked both GH and also cleaned flow meters again, better. All perfect though.
          Now i can say they both stays on during heating and flashing when the button for brewing been switched on. (after getting the right boiler pressure). I think there is a certain progress.
          It gave me few drops from one GH for a while but nothing more. Otherwise same.
          As Perfect for writing about the inlet valve Ive realized i omitted one short section of piping thinking thats only connection, not important as the water goes through in. There is, i assume the valve with a piston stuck open, i hope. that should solve it.

          Another thing. Ive found out, that the resistance of the working solenoid coil should be 0.7-0.8 ohms. Mine has 0.66 and 0,69.
          Is it bad, already for replacing?
          Also just curiosity about flow meters: in few articles guys writing about resistance between 0 and + terminals should be 2.2 kohm
          Seems to be not confirmed checking. Anyway i didnt get any measurement at all.

          I will keep updated THANKS


          • #6
            Hi guys, finally back. I went trough the whole thing again. Everything clean and seams to be working but the pressure is still low. Now i have stupid but maybe important question. Is the water inlet tap (number 5 on the pic) supposed to be open or closed.
            (Could it possible be the manual fill valve, Perfect mentioned above)


            also a detail pic of the machine piping


            Many thanks Sima
            Last edited by sima; 9 January 2015, 09:30 AM.


            • #7
              In the first picture, the rear black-handled ball valve is the manual fill valve - to the left of that valve is the inlet water feed from the pump, the right hand side is the water feed to the boiler.
              The front valve is a shutoff to allow replacement of the inlet solenoid without draining the boiler - this one should be left open, the rear one should be closed. In the pics, both of them are in the open position.


              • #8
                Beaten by Morgan but this pic might help a little. The manual fill valve on your hydraulic drawing is like this one as used in a San Marino Lisa that can be operated from the front of the machine where yours it's just a straight ball valve.
                Attached Files


                • #9
                  Thank you so much guys, love this forum!!! You all saved me hours of testing and fighting. I thought it could be the last problem after all. I`ve tasted it and the result are great. When the brewing button is on the pressure goes straight to 9 bars. Both groups works now. Do you guys know what is the purpose of the manual fill valve? Why do you have the option to leave it open? And one small thing to finish it off. Now I have a leak and steam coming out of the top of the boiler pipe. There wasn't any gasket just a bit of old white tape. Do you know which tape can hold the heat? Or should I get just copper gasket? And as a last one: on the group solenoid was a clear plastic foil to protect it from the wet. should I get any special one for this purpose. Thank you heaps for everything guys! Sima


                  • #10
                    I know this is an old thread but I'm hoping there's still some interest because my son has just bought one of these and is having similar problems. First of all the boiler isn't filling with water. I'm assuming that if I open the manual ball valve then it should fill regardless of whether the solenoid valve is working or not (though if this is the one under the drip tray centre/front of the machine I think it is). However it was purchased with a full boiler so I'm assuming whatever is stopping it filling is something that's developed while it's been in storage. Steam and boiling water are produced ok but when the brew button is activated the pump starts making the right sort of noises but a very weak trickle of water and some steam is all that come out of the GHs.

                    Anyone got any ideas what I could check?