Announcement

Collapse
No announcement yet.

Timbo's 1st restoration - La Cimbali M20

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Timbo's 1st restoration - La Cimbali M20

    After all of the sweet-talking of Cimbali's on here (admittedly mainly from JavaB, and Java "has an unhealthy thing for Cimbali's" phile), I took the risk and made the BRILLIANT (ie: really stupid) decision to win an old M20 on ebay.

    It was local, a good price and complete, but it's obviously done it's fair share of work and had a few leaks in it's time. It was pretty grubby under it's clothing, but after a few checks and a good clean of the group head, it made a decent coffee. I'm coming from a 6910, and while I was expecting a huge difference in some ways, I wasn't expecting such a huge difference required to HOW to prepare for a shot and steam the milk. So unforgiving, and I have a lot to learn The first thing to learn probably should have been "why an 11L boiler HX machine is not a sensible home espresso machine"....

    Anyway, here are some shots of the condition as it stands, and I've received a bunch of spares from coffeeparts.com.au to start the resto (damn they are quick!).

    Cheers,
    Timbo















  • #2
    Things that seems to work OK.
    - Both steam wands (but have bought new o-rings/seals etc anyway)
    - hot water wand (but have bought new o-rings/seals etc anyway)
    - Manual fill
    - Auto fill (when the level sensor is bypassed)
    - HX and group bits
    - Seems to have a new over pressure valve and anti-vacuum valve fitted
    - Sirai pstat looks newer that the rest of the machine, but maybe it is just in a cleaner part of the machine
    - wiring is in good shape
    - procon rotary pump works (but does show signs of previous leaks)
    - boiler doesn't seems to leak (but also shows signs of previous leaks, so I have new gaskets for the rebuild)


    Things that need work
    - Chrome on steam wands is not good, so trying to work out whether to rechrome or replace... either way will cost a lot
    - level float (I'm hoping it's just scale, because they're not cheap either!)
    - the pressure gauge (the pump side is OK, and while the boiler side does reacts correctly, it sits on half a bar when cold and about 2bar when hot)
    - the frame needs a full clean/strip/paint and the stainless needs a good polish
    - most of the knobs are floppy or broken
    - many of the gaskets and connections show evidence of leaks.
    - the rotary pump (made in australia apparently!) will likely need a new o-ring at least

    But all in all, I think it should be a good base for a resto.

    One thing i was wondering about was the material for the boiler... I was expecting to see an oxidised copper boiler like many machines on here, but this one looks more like an extruded alloy tube with a plate welded at one end, and a case alloy plate bolted at the other. Is this a higher/lower cost alternative to a copper boiler, or is it just that machines from different eras used different materials?

    Cheers,
    Timbo
    Last edited by Timbosaurus; 30 March 2015, 01:23 PM.

    Comment


    • #3
      So far, the dates i can get from the printing on some of the parts are 1989/1990, so I'm guessing this is of 90/91 vintage.

      The rating on the machine is something like 6.3kw, but I've measured each element at 4.3A @ 240V from cold. Given the pump is ~150w, it seems to be more like a 3.2kw machine. So would the ratings on the machine assume a higher voltage across the elements (eg: 380V) to come up with the 6.3kw total? or should I assume that the elements have been swapped for smaller ones at some stage?

      Cheers,
      Timbo

      Comment


      • #4
        According to the parts list on coffeeparts the element should be 3750w, the 3 group takes a 5790w element which seems more in line with the 6.3kw rating. Perhaps the data plates were switched at birth?

        Comment


        • #5
          Hi Magnafunk,

          When I picked up the machine it was fitted with only a 10A plug, which scared me witless given the 6.3kw rating! I disconnected 2 of the elements for all my testing (to be safe), but now that i've measured it at 4.3A per element, I'm comfortable running it on a 15A circuit.

          Here is the plate which seems to line up with the boiler ID, and clearly says 6.3kw. I guess it'll always just be a mystery...

          Comment

          Working...
          X