No announcement yet.

Cimbali M21 Plus Autofill Broken

  • Filter
  • Time
  • Show
Clear All
new posts

  • Cimbali M21 Plus Autofill Broken

    Hi Guys,

    I have a 2grp La Cimbali M21 Plus that this morning decided to develop an autofill issue.

    Basically, the autofill is just staying on and not turning off. Normally it turns on for a few seconds (as its supposed to do), and then turns off again.

    I left it on for a bit to see if it would stop, but it doesnt seem to be, and I've lost sight of the little float in the sight glass (but boiler has not yet filled up so much that water is coming out the steam wands.

    I *think* i have located the autofill probe, the top black wire:

    But I tried disconnecting the wire, and it still didnt turn off (well, I tried disconnecting it and turning it on, but the autofill still activates...i didnt actually try disconnecting it whilst powered on).

    So I'm a bit stumped as to what else I can try to fix it.

    Does anyone have any ideas on what else I can try?

    Thanks in advance guys,

  • #2
    If you earth the autofill wire, in this case it would be easiest to just touch it to the boiler, the autofill should stop. Earthing it replicates the probe touching the water in the boiler.

    Possibly the autofill probe has a build up of scale which is stopping it from touching the water and telling the autofill to switch off.
    Remove the probe and clean it with a wire brush or sandpaper to remove any scale. This should hopefully sort it out.

    If this doesn't work or earthing the wire doesn't stop the autofill then there is something else wrong.
    Check the wire for any damage or breaks.

    If there's still no luck then the autofill on the circuit board is probably faulty. This is quite rare though.


    • #3
      Okay so I've disconnected that wire and touched it to the boiler, it doesn't stop the autofil.

      I then removed the probe and cleaned off the scale and put it back in.

      Still no dice.

      I've traced the wire back until it disappeares into a mass of wires under the boiler. Doesn't seem to be breaks. Is there any sort of autofil control box or is it just on the circuit board?


      • #4
        Not 100% sure but I think the Cimbali uses a fairly primitive Gicar control box, an RL30 or similar. Someone with more knowledge on this particular machine may know better.
        It is possibly located under the drip tray, perhaps under a metal cover.

        I've not encountered a faulty autofill on a Gicar box before however the circuitry is mostly surface mount and not really designed to be repaired.

        Does your machine have any sort of manual override switch to control the autofill? If so, it might be shorted and constantly telling the machine to fill up.


        • #5
          Hmm, no manual override as far as I can tell, and also there doesn't seem to be any Gicar control box (or that magnetic flow control thing thats pictured on coffeeparts either, I looked for both).

          Here are some photos of inside the metal box under the drip tray, and of the level probe.

          The red arrow in the last photo shows the wire that traces back to the level probe.

          But there doesnt appear to be a Gicar box anywhere, and ive tried googling for another control board, but cant find one anywhere.


          • #6
            Have you checked the continuity/resistance between the inside portion and the wire connector of the probe and the two ends of the wire?

            Java "Easy things first" phile
            Toys! I must have new toys!!!


            • #7
              There must be a connector somewhere between the black and yellow wire, it might have come loose or be damaged in some way. Checked continuity like Javaphile said.

              Also, the area of the board I've circled doesn't look too good. Being that these components are so close to the autofill wire, there could be something amiss there. Give it a clean with some contact cleaner and light abrasion.


              • #8
                Okay, I have traced the wires all the way back to the board.

                The two black wires coming out the boiler int he first photo (one from the level probe and the other from behind the screw), both feed into a connector where the level probe wire becomes the yellow, and the "screw wire" becomes 2x red wires, which I believe are the two red wires to the either side of the yellow in the last photo with the arrow pointing to it.

                One of these red wires was cut (as was a white wire which goes up towards the group controls (dont think the white wire is related).

                I stripped back both cut ends of the red wire and joined them with electrical tape (just to test).

                Now there is continuity between the probe and the yellow wire at the control board connector, and each of the red wires, and between the Screw Wire and both reds.

                .....yet when I turn it on, the autofill still keeps filling.

                Also, that dirty area on the board was just a piece of dust or something. Blew it and it went away.


                • #9
                  Okay, so I have made some progress, and not quite sure which of the things that I did were responsible for it. After my above post, I decided to try cleaning the entire board with contact cleaner and letting it dry. So I did that.

                  Then, after I thought I had let it dry long enough, I turned it back on.

                  This time, the autofill stopped!...then turned back on, then off, then on, then off, then the machine beeped again as though it was starting up. So I quickly turned it off, presuming that I hadn't let the contact cleaner dry fully and it was shorting somewhere.

                  So I got a hairdryer out to dry out the board (even though it looked dry already).

                  Then I thought maybe the taped wires were not really making proper contact, so I went and got some contact connectors (like these: Contact Connectors - Wire Joiners - Pk.4 | Jaycar Electronics) and clipped the wires properly.

                  Then I waited about 20minutes and tried again.

                  Much better. This time it came on as normal. Autofill engaged for a second, then turned off and didn't come back on immediately, so i turned it off again and reassembled the machine to test more fully.

                  When I was done, I turned it on for a longer test run.

                  It basically works properly except:-

                  1. It used to only activate the autofill very occasionally, and never more than once in any noticeable period unless you were drawing a LOT of steam or hot water out. Except now, it seems to come on and off quite regularly during the heatup phase, but then once its been on for a while, it seems to stabilize and only come on rarely as before. Could this be a simple byproduct of cleaning the probe so its now more "sensitive" than before?

                  2. There are 5 buttons on the touchpad: single dose single cup, single dose two cups, manual, double dose single cup, and double dose two cups. The first 3 work on both groups. The 4th works on the left group only, and the 5th doesnt work on either group. I push the button, and the pump activates for a split second and then deactivates. However, I'm not really sure if these ever worked properly as a I never use those buttons (frankly, I don't really see their purpose). They could have always been broken and I just not noticed, or they could have "reset" their custom fill levels to "zero" (hence the immediate shut off).

                  So in short, its back working again, but it seems to have acquired a few poltergeists along the way.

                  So thanks very much for the help. I would have given up without the suggestions.

                  Finally, just out of interest, a closer inspection of the control board reveals an "M30 Dosatron" sticker on either the M21 Plus was always sold with the M30 control board, or it has had control board issues before.