Announcement

Collapse
No announcement yet.

Pressure Problems - Reneka Techno V2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pressure Problems - Reneka Techno V2

    I am having pressure at the group head problems on my (10-11 year old) Techno.

    Pressure gauge on machine measures pressure at the exit from the pump head - not at the group head.
    Pump is rotary.

    Gauge measures 0 bar when water inlet off. 3 bar when water inlet on.

    When using either blind filter for backflushing OR basket with coffee in max pressure on gauge is 3-4 bar.

    Adjusting pressure valve (on pump) makes no difference to pressure reading on pressure gauge.
    Three way valve on solenoid releases after every shot.

    Backflush works as normal - can see suds coming back up out of drain in drip tray and hear valve release.

    Group head clean. Shower screen clean. Plate removed - all holes clean.

    Water debit on a shot normal/as programmed.

    Minimal/no crema on coffee.

    When pouring a shot it is either (depending on grind): dripping slowly (brown/blonde) or running fast and blonde.
    No in between.

    Any ideas much appreciated.

  • #2
    Assuming there is no problem with your pump (or the pump inlet), it sounds like there might be water leaking from the brew path somewhere?

    I don't think a blockage would be consistent with your observations.

    Comment


    • #3
      Thanks MrJack.

      No leaks.

      Sounds like pump or motor problem.

      Motor v.warm - overheating trying to turn pump.
      Pump not turning freely when taken off, but still turning (with screwdriver in drive shaft).

      One/both of them must be at fault.

      Comment


      • #4
        Sounds like the pump/motor bearings are dry. The bearing may be bushes rather than ball bearings.

        Comment


        • #5
          If more power is required to drive the pump, then less power is available to be applied to the water (which limits both flow and achievable discharge pressure). Sounds like a good place to start!

          Comment


          • #6
            Try disconnecting the pump from the motor and then see if the motor spins freely. I just had a pump with the same problem on my La Cimbali. The pump is being rebuilt now.
            Last edited by mcudogs; 29 November 2016, 10:33 AM.

            Comment


            • #7
              Motor spins freely.
              Pump does not spin freely.

              Comment


              • #8
                Rotary pumps do not actually "spin freely" per sé...
                They do offer a reasonable amount of resistance to rotation due to tight fitting shaft seals and friction between the eccentric vanes and the pump body. You should be able to rotate the pump shaft (with an open head) with your fingers though, and not require any additional force assistance with the use of spanners or screwdrivers, etc...

                Mal.

                Comment


                • #9
                  Hi Al.

                  Does the pump sound normal in operation. Sound will tell you a lot.

                  A portafilter with a pressure gauge is really the only way to measure the group pressure properly.

                  A new rotary pump is about $200. It isn't a big deal putting one in except you will need to check and maybe change the pressure so you will need the pressure gauge for head pressure measurement.

                  Comment


                  • #10
                    Originally posted by wattgn View Post
                    Hi Al.

                    Does the pump sound normal in operation. Sound will tell you a lot.

                    A portafilter with a pressure gauge is really the only way to measure the group pressure properly.

                    A new rotary pump is about $200. It isn't a big deal putting one in except you will need to check and maybe change the pressure so you will need the pressure gauge for head pressure measurement.
                    You're not likely to see an increase in pressure between the pump gauge and one at the group, so unless there is a problem with the gauge, it's fine for diagnosis...

                    Comment


                    • #11
                      Thanks for your replies Mal and Grant.

                      The pump sounds normal in operation, but there's no water flow.

                      The machine is now about 11 years old and I think it needs a complete strip and rebuild (looking more closely inside suggests to me this is now a must) plus some Techno mods I've read about to manage water flow (the Techno's ability to go from slow drip to gushing flow between shots has been a bugbear).

                      Alternatively I buy a new machine.

                      I am leaning towards a new machine now.
                      Reneka is virtually absent in the Perth market.
                      The Techno ceased production about 4-5 years ago and has several proprietary parts (heating elements and brain box). While I could source those direct from Reneka easily, putting $000s into this machine doesn't seem worthwhile. I think I am at a point where it will be a slow death cycle of failures (elements really are around end of life for this machine now).
                      11 years on an initial $3,300 investment was a great return.
                      I never really loved it and I think it may be time to move on.

                      Comment


                      • #12
                        Happy to take the Techno off your hands if you're going to buy a new machine and throw it away... 😆

                        Comment


                        • #13
                          Almac. It is a bit tragic. Parts availability is a an issue for you.

                          Comment


                          • #14
                            Originally posted by MrJack View Post
                            Happy to take the Techno off your hands if you're going to buy a new machine and throw it away... ��
                            I'll let you know if it comes to that.

                            In the meantime, I've put it in my garage in the hope it will turn into a new coffee machine and rekindled my association with plunger coffee.

                            Comment


                            • #15
                              Plunger coffee is good. Kept me going when my Bezzera needed a new pump.

                              Comment

                              Working...
                              X