No announcement yet.

Moka Pot Problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • Moka Pot Problem

    Hi there,

    I am new to the Moca Pot Scene. I bought a cheap one for $30 from homeart, I am unsure if this is my problem
    so here is what's going on

    First time i blended a coffee, i had no problem, after this i took the pot apart and cleaned with water, dried with paper towel and left the parts disassembled in the
    pantry to make sure it was properly dried, i then stored my Vittoria's Ground Espresso commercial link removed per site posting policy in the pantry in an air tight container.

    Today i have gone to make a coffee using the same method. to no avail, it just sat there and boiled the water on my gas cook top. After seeing some advice from this
    site, i tried to mack it, thinking it was the coarseness, again same problem, i then troubleshoots the Moca pot, with no coffee it works perfectly, but comes out with a
    lot of pressure, coming out of the lid if i don't hold it down, after this i tried half of the filter pot filled with coffee, which did not work again. Finally, i tried a very small
    amount of coffee in the filter bucket, i mean around 5mm thick, this seemed to work, but i only got a very small amount of coffee before it just started boiling like crazy again

    I am thinking it is the coarseness of the grind, I am in north Melbourne, but i dont think there is any roasters close to me, so i am stuck with supermarket bought beans, but i don't
    want to spend a fortune testing out supermarket grinds, i am suspecting my grind it way too fine, even though the packet states its good for moka pots. So here i am puzzled. Any
    Advice will be much appreciated, as i really want to enjoy home made espresso. once successful, i will more than likely venture out to buy a more expensive grind. (then again when vittoria
    sell a pack like this, commercial link removed per site posting policy i'm even more puzzles

    I am also brewing on the smallest gas burner at a high heat for testing, if this is wrong let me know, the box states i need to use a low heat, but this takes a good 30 minutes
    Last edited by Javaphile; 6 August 2014, 03:07 AM. Reason: Commercial link(s) removed