Announcement

Collapse
No announcement yet.

Sunbeam 6910 - no steam!!! HELP!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sunbeam 6910 - no steam!!! HELP!

    Let me preface by saying I LOVE my 6910, but have had issues with the steamer in the last few months. I turn it on, and...nothing.

    Rang Sunbeam and the very helpful fellow suggested running the hot water for a minute or so, then turning on the steam control dial to full, and it would blow out any blockage.

    This worked the first couple of times I had issues, but not now.

    Anyone had a similar problem? Solutions? A mocha aint a mocha without textured moo!

  • #2
    Re: Sunbeam 6910 - no steam!!! HELP!

    Welcome Mochamaker - I have never heard of it...I would ring them again and take it up

    Comment


    • #3
      Re: Sunbeam 6910 - no steam!!! HELP!

      I dont understand how their workaround is meant to clear any blockage unles the steam pump also pumps the hot water.
      Logic would suggest the main pump does both the hot water and the shots.

      I had a similar problem with the 6900.
      Diagnosed as a pump problem.
      When it got to Sunbeam it was working again so they fixed the other problem it had and sent it back.
      It lasted 5 more days and stopped again.
      Second time around they gave us a new 6910.

      Speak nicely to them, mention that the previous fix was temporary.
      Its obviously and intermittent problem at the monment but to me a sure sign it will die eventually.

      Comment


      • #4
        Re: Sunbeam 6910 - no steam!!! HELP!

        Mochamaker - yes I had the same problem. Mine started out being a bit intermittent for a week or so and then stopped working altogether. Turn the dial and nothing.

        I took it to the service agent (still under warranty at the time) and he repaired it - said it was a faulty switch. I dont know if they had to replace it or if it just lost a contact somewhere and they adjusted something.


        Cheers.

        Comment


        • #5
          Re: Sunbeam 6910 - no steam!!! HELP!

          I had the exact same problem

          With mine the knob had become loose, (there is a micro switch behind that is activated when the knob is turned.)
          Try pressing the knob in towards the machine when turned on.

          I ended up with the knob coming off in my hand. I managed to fix it by drilling a small hole in the end, then using a philips screwdriver tighten the screw back onto the shaft!

          hope this helps

          Chris

          Comment


          • #6
            Re: Sunbeam 6910 - no steam!!! HELP!

            There was no need to drill a hole.
            The knob comes apart.
            Theres an outer and inner piece.
            If you take the outer piece off you can screw it the inner piece back in place then pop the outer shell back on.

            Comment


            • #7
              Re: Sunbeam 6910 - no steam!!! HELP!

              OK, Ive tried pushing the knob in while turning it, but nothing. Ive removed the outer ring of the knob but cant seem to see where Ive got to screw (so many jokes could be made here). It looks like the knob actually comes off, but I dont want to pull it just in case (insert joke here too).

              Im thinking I might just visit the service repair fellow armed with the info youve told me about the microswitch!

              Thanks for you help.

              Comment

              Working...
              X