Announcement

Collapse
No announcement yet.

EM 6910 Cleaning problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • EM 6910 Cleaning problem

    Can anyone tell me why my Sunbeam EM 6910 no longer wants to back flush the way it always has. With the group handle in place I have always pressed the function button until it starts to go silent and then released it. The group flushes with quite a hissing sound. Now the pressure builds up but does not release until the handle is removed. Water oozes out of the hole at the bottom of the machine at the back of the drip tray. When I use a cleaning tablet all the water comes out of the hole at the bottom instead of out of the group head. I had switched the machine on to do this cycle and walked away. I came back to a flood in my kitchen. This has never happened before.

  • #2
    Re: EM 6910 Cleaning problem

    Sorry. I meant to say the manuel button (not the function button)

    Comment


    • #3
      Re: EM 6910 Cleaning problem

      Originally posted by 7A73614D7077737C120 link=1256992696/0#0 date=1256992696
      Can anyone tell me why my Sunbeam EM 6910 no longer wants to back flush the way it always has. With the group handle in place I have always pressed the function button until it starts to go silent and then released it.  The group flushes with quite a hissing sound.  Now the pressure builds up but does not release until the handle is removed. Water oozes out of the hole at the bottom of the machine at the back of the drip tray. When I use a cleaning tablet  all the water comes out of the hole at the bottom instead of out of the group head. I had switched the machine on to do this cycle and walked away. I came back to a flood in my kitchen. This has never happened before.
      Scale and or a problem with teh solenoid valve... Is what it sounds like, in teh first instance...

      Then again... Are you using teh rubber blind ??

      Comment


      • #4
        Re: EM 6910 Cleaning problem

        Originally posted by 232A3814292E2A254B0 link=1256992696/0#0 date=1256992696
        When I use a cleaning tabletall the water comes out of the hole at the bottom instead of out of the group head.  
        Originally posted by 232A3814292E2A254B0 link=1256992696/0#0 date=1256992696
        I have always pressed the function manual button until it starts to go silent and then released it.  
        Pressing the manual button is not how you start a cleaning cycle with a cleaning tablet.

        See page 31 of the Instruction Book for the correct procedure.

        However, that doesnt fix your current problem.
        If you havent been cleaning it properly it may be too gunked up to run a normal cycle.

        I hope AM or Graham have a suggestion for you.

        Comment


        • #5
          Re: EM 6910 Cleaning problem

          Thanks AM and T/God.

          Yes I do use the rubber disc, and my machine is descaled and cleaned very regularly. I am paranoid about cleanliness!!
          T/G you are right about not pressing the manual button when using the cleaning tablet. I only press it when I flush with the rubber disc (we were shown how to do this at the Sunbeam course) The rest of the time I follow the instructions in the book word for word.
          I have never had trouble with the machine until this week and I use it every day. It still seems to be brewing okay. Just the cleaning part is the issue.

          Comment

          Working...
          X