Announcement

Collapse
No announcement yet.

Em6910 - No pressure to group head

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Em6910 - No pressure to group head

    Just given a Sunbeam EM6910 (thought it might make a good spares donor) i have a perfectly working one in Kitchen, used daily) I fired it up and it steams and runs hot water just fine ... problem occurs when using single or double head, no pressure and dribbles of under extracted coffee. If i use the rubber blank in the double , pressure reads into the orange (midrange) but does not go higher (waited a few seconds) if used with single , it reads low orange .. again just tested for a few seconds. would love to get it up to speed - Previous owner tried to replace the group head seal (it now has a blue one) old one on inspection had split... all other functions seems fine as stated.. although it does not make the same noises as my working unit. any advice welcome - happy to take to Melbourne service agent if available. Many thanks Frase :-[

  • #2
    Re: Em6910 - No pressure to group head

    Remove the shower screen and check it is clean.

    you can also then try running water (no coffee) through the machine without the shower screen

    Comment


    • #3
      Re: Em6910 - No pressure to group head

      Originally posted by 496B756B4470637167020 link=1299416725/0#0 date=1299416725
      problem occurs when using single or double head, no pressure and dribbles of under extracted coffee. If i use the rubber blank in the double , pressure reads into the orange (midrange) but does not go higher (waited a few seconds)
      1: The rubber blank with teh hole and Single floor basket and mid range is Fine... All ok.

      2: Have you tries other baskets from you machine ?

      Remember to only use single floor baskets with coffee.

      Try a Double floor basket ( When you look you can see NO light) and NO coffee.

      Comment

      Working...
      X