Announcement

Collapse
No announcement yet.

6910 steam wand issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 6910 steam wand issues

    hi Im hoping someone can help me out.

    There is no steam coming out of the steam wand. I turn it on and nothing, no sound of the pump working. I checked the steam wand and its not blocked. I did have the same issue about a month ago but it just fixed itself and hasnt skipped a beat since. I bought the machine bout 4 months ago second hand, its about 2 years old. I use it about 3/4 times a day If it is the pump is it expensive to fix as I dont have the reciept for it...

  • #2
    Re: 6910 steam wand issues

    Chances are its either the steam pump or the switch. Pull the steam handle off and make sure the switch is operating properly. There should be a good solid audible click when you twist the steam knob. So clean out any gunk etc near the switch or make sure the switch hasnt become dislocated etc. If thats ok then consider replacing the pump. A steam pump should cost approximately $30 - $60 depending on where you source it from. It can be a bit tricky to fix so only attempt it if you consider yourself mechanically minded. The main difficulty is squeezing the old pump out and putting the new one back in without damaging anything, its a bit of a tight fit, but certainly not a job beyond the confident handyman.

    I did this recently so a quick tip if you attempt this - once youve pulled all the panels off (with the machine off of course) you should be able to access the pump easily, unplug the red and black wires from the old pump and plug them into the new pump. Turn the machine on and turn the steam handle, hopefully the new pump kicks into life, otherwise theres no need to replace the pump and your lack of steam relates to a problem with wiring or the mainboard  which basically means you need to send it to a service centre for them to assess.

    FYI - i got my steam pump from http://www.bigwarehouse.com.au/ for about $35ish they said it was in stock before i purchased it, but after a week they apologised saying it wasnt in stock, so in total it took about a month or so to arrive. Looks like the price has gone up to $60ish now tho so maybe look around elsewhere.

    Comment


    • #3
      Re: 6910 steam wand issues

      I still do get the click when i turn the steam knob.. ill ring sunbeam today and see what they cant do, if they cant help me out i might do the mechanics myself... thanks tommy ill have a look around and let you know how i go with it all..if i get stuck your my first port of call...

      Comment

      Working...
      X