Announcement

Collapse
No announcement yet.

Whats wrong with my silvia

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Whats wrong with my silvia

    I got myself a Silvia about a month ago (second hand but well looked after by a forum member) and have been enjoying her enormously. I generally make myself a couple of double shots each morning during the week and like to get really edgy on weekends.

    This morning I rose from slumber, switched her on and when I came back later she was not hot as expected or even remotely looking like heating up.

    Water ran from the group, and wand, but cold...

    I thought that this is one of those boiler reset problems, so home from work I whip the lid off, identify the reset button and give it a push. Nothing much happens, boiler remains cold and I notice that the reset button appears loose, theres no friction on it, and you can slide it in and out.

    Im figuring its a job for a technician now, thinking perhaps that the thermostat has died - but I dont get why? It worked fine yesterday, then today nothing :-/


    cheers

    grant

    BTW, the boiler was primed, I make only espresso and havent ever boiled her dry

  • #2
    Re: Whats wrong with my silvia

    Had the same symptoms on my three-month old baby last month. Tried the thermostat reset without success. It turned out to be the element. Very odd fault in a machine with such a strong rep for reliability! 
    Anyway, it was replaced under warranty by a local technician, arranged  and paid for by the vendor (Coffee-a-Roma - thanks Guys, great service!). It seemed to be a relatively easy fix for him, with labor the main cost. Im sure many brave CSs would do it themselves if their machine was out of warranty. (Element, boiler gasket, elbow grease). All well again now and Sylvias producing the goods!
    My opinion - make friends with a tech!

    Martin

    Comment


    • #3
      Re: Whats wrong with my silvia

      Got a multimeter handy? You can test the components for continuity and find out whats causing the problem that way, you should get a stable reading of about 55 Ohms across the element if its good, and 0 ohms across thermostats and safety switches. If anything is open circuit (very high / infinite resistance), theres the problem. The terminals should be disconnected to test and... unplug it from the wall 

      Or - just take it to a tech! The bad news is if its the new style element its brazed into the boiler so the whole boiler needs to be replaced.

      Comment


      • #4
        Re: Whats wrong with my silvia

        Originally posted by 28333931053835343E5A0 link=1320305711/2#2 date=1320313920
        Got a multimeter handy? You can test the components for continuity and find out whats causing the problem that way, you should get a stable reading of about 55 Ohms across the element if its good, and 0 ohms across thermostats and safety switches. If anything is open circuit (very high / infinite resistance), theres the problem. The terminals should be disconnected to test and... unplug it from the wall 
        I have a multimeter, so will test it this evening and hope for the best. Unplugged you say?

        cheers

        grant

        Comment


        • #5
          Re: Whats wrong with my silvia

          Hi Grant;

          Check if your safety thermostat has pop out, maybe someone in the house forgot to switch the steam mode and is over heating, other wise do what rick_bond said.

          If you need a new boiler we have it in stock, is not hard to change.

          Regards

          Renzo
          Di Bartoli Home Barista Centre


          Comment


          • #6
            Re: Whats wrong with my silvia

            Just checked with my multimeter and I get nothing across the element

            Thanks for the help guys, at least I know now what I have to do.

            Cheers

            grant

            Comment


            • #7
              Re: Whats wrong with my silvia

              Originally posted by 272F223F38262F334A0 link=1320305711/1#1 date=1320306875
              Had the same symptoms on my three-month old baby last month. Tried the thermostat reset without success. It turned out to be the element. Very odd fault in a machine with such a strong rep for reliability! 
              Anyway, it was replaced under warranty by a local technician, arranged  and paid for by the vendor (Coffee-a-Roma - thanks Guys, great service!). It seemed to be a relatively easy fix for him, with labor the main cost. Im sure many brave CSs would do it themselves if their machine was out of warranty. (Element, boiler gasket, elbow grease). All well again now and Sylvias producing the goods!
              My opinion - make friends with a tech!

              Martin
              Martin, how long did the fix take? Ive had my Silvia for a month now and all of a sudden, no heat, and the reset button doesnt fix the problem! I bought it from the same vendor and Im hoping to organise a fix tomorrow. Unfortunately I discovered the fault at 11pm on Thursday night Its very strange that a machine with such a strong reputation for reliability goes down so unexpectedly although the coffees are amazing when it does work...

              Comment

              Working...
              X