Announcement

Collapse
No announcement yet.

EM6910 - Collar and Group Head Seal symptoms

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • EM6910 - Collar and Group Head Seal symptoms

    Good afternoon.

    My 6910 is around 4 years old, and working fine.

    20 lattes a week, and around 10 espressos.

    I only use filtered water, and use a cleaning tablet at the start of each month.

    The only problem that I have is that the group head handle now sometimes wants to move to the left when pulling a shot - quite spectacular when it let go, and a huge amount of wet coffee grinds everywhere!

    I checked out a couple of threads on this, and saw people having to replace collars and group head seals.

    What are the symptoms, please?

    Is it worth driving to the other side of Adelaide to get it serviced?

    Thanks, folks.

    Chris

  • #2
    I'd try a new seal or a spacer under it first before spending money on a collar.

    Comment


    • #3
      Thanks.

      Do you know what the symptoms are that point to a seal replacement being necessary?

      Cheers.

      Comment


      • #4
        Originally posted by chrisl View Post
        Thanks.

        Do you know what the symptoms are that point to a seal replacement being necessary?

        Cheers.
        4 years' use would be the most obvious one... followed by the portafilter unscrewing

        Comment


        • #5
          Originally posted by chrisl View Post
          Thanks.

          Do you know what the symptoms are that point to a seal replacement being necessary?

          Cheers.
          I'm pretty much in the same boat - except mine does't "unscrew", just leaks like crazy if I'm not careful. Think I'm just going to replace the seal and hope that's all vs. a new collar. Would also be interested in the reasons for replacing a collar vs. just the seal.

          Comment


          • #6
            ....sad news, just replaced the seal, was feeling confident after giving it all a good clean out (needed it!). Ran descaler through it. Tried the group handle on, all looking good. Tried a backwash (hasn't had one in too long due to the leak) - water water everywhere :-(

            Tried pulling a shot, and it's a little better than it was, but still leaking.

            Guess it's a new collar for me :-(

            Comment


            • #7
              A sign of a worn collar is the handle locking way to the right.
              Are you sure you've installed the new seal correctly?

              Comment


              • #8
                Originally posted by Thundergod View Post
                A sign of a worn collar is the handle locking way to the right.
                Are you sure you've installed the new seal correctly?
                Thanks,

                ...there didn't seem to be much to get wrong. But yes, the handle goes ALLLLL the way to the right - until a hard stop is felt... Any tips on things to watch for on the seal change..!

                Comment


                • #9
                  ....collar changed, seems to be a big improvement, much tighter. Still seems to leak a little on backwash with blind filter though. I'll give it a little time for it to re-settle as it's improving, then might replace the blind filter too. Have at least been able to give it a proper backwash - first in a long time!!

                  Comment

                  Working...
                  X