No announcement yet.

Sunbeam EM6910 possible powerboard issue

  • Filter
  • Time
  • Show
Clear All
new posts

  • Sunbeam EM6910 possible powerboard issue

    Hi All,

    Hopefully someone can help me here. My Sunbeam em6910 which is approximately 3 years old has started playing up.

    Problem first started when I tried to use it after an extended period of non use. Initally made sure water ran through nicely without group head in place the added coffee grounds and put group head in place. Hit the manual pour option but water wouldn't come through group head. From memory pretty sure I then hit the manual button but no response so had to turn it off at the wall.

    Decided I would let it dry out for a while then start it up again yesterday. I powered the unit on, let it run through normal power up cycle, press manual pour button - without group head in place - water starts to pour out from top and also into drip tray and underneath unit. At this stage the unit does not respond when I hit the manual button again nor if I hit the power button. I have to turn it off at the wall.

    Does this sound like a powerboard only issue (that needs replacing)?

    My next step is to take it to a repair place on the sunshine coast however I would like to know if anyone here has any tips or tricks to troubleshoot/fix it before I send it in?

    Also, any tips for stopping this from happening in the future? When the unit hasn't been used for a while.



  • #2
    If water came out through the drip tray as well as the group head that means your 3-way solenoid valve is open when it should be shut. The first time you tried it and no coffee came out, did you notice water pouring into the drip tray as well? This would explain why no coffee was coming out as there was no pressure due to the valve being open. That would also mean the fault hasn't worsened. It's the same fault but is not being exhibited in a different way.

    If the manual pour button isn't responding then it sounds like the PCB is triggering the solenoid when the button is pressed then not responding again. Would most likely be the PCB at fault, solenoid could also be faulty but I can't see it affecting the operation of the buttons.

    The solenoid may have stuck open though if a piece of scale or coffee debris has been sitting in there for some time. This would make sense being that you didn't use if for an extended period. Why this causes the machine to operate incorrectly I'm unsure of. The PCB might know that the solenoid is open and think it's in a state of non-brewing so that's why the manual button doesn't work for a second time (because it already thinks it's open and completed brewing).

    TL;DR Probably PCB, check solenoid valve as well.


    • #3
      Thank you for your detailed response noidle22. It is really appreciated. I took the machine into the recommended repairer and they confirmed it is the pcb. Its all ready to be picked up.