No announcement yet.

NS Oscar Brain Box Troubleshooting

  • Filter
  • Time
  • Show
Clear All
new posts

  • NS Oscar Brain Box Troubleshooting


    After no response in a WTB thread I thought I would take one more shot at trying to fix the Gicar before buying a new one.
    Just a few things for a struggling wannabe
    On turning my Oscar on, the element light turns on for about 2 seconds, there is a electrical hum from the Gicar and the water indicator and element light start flashing.
    I think the water light flashes on, Gicar then turns the element off. The water light flashes off, the Gicar turns the element on.
    I have changed Relay 3 and the transformer on the Gicar box. These two original parts had burn marks on them.
    The side where there are 7 wires is the AC side right?
    I checked the capacitor on this side and i get a reading of .5V AC. Is this too high?
    I checked the ribbon and i get about .5v DC. Is that right?
    This is with the machine power button off but the wall plug on. Yes, I know, I'm playing with a hot box.
    I changed relay 3.
    This did not fix the problem. I get a flashing water fill light. When the water light flashes on, the boiler goes off, and vice versa.
    After leaving it to flash for about 30 seconds, the new relay 3 burnt out because the led in the relay stopped flashing and the boiler light did not alternate on and off with the water fill light anymore.
    I changed the relay and the transformer. I still get the flashing on and off light from the water fill and boiler lights.
    The capacitor does not seem swollen. There are no other burn marks on the board. I have not touched relay 1&2 as I figured relay 3 would not work at all if there was a fault with 1&2. This could be wrong.

    Ive attached a picture of the unit.
    Do you have any suggestions?
    Thanks for your time,
    Attached Files

  • #2
    Originally posted by denwol View Post
    Do you have any suggestions?
    Purchase a new one from Casa Espresso and bin the cooked one


    • #3
      If you could send me a more high quality photo of the front and back I may be able to help. Have you checked the diodes?

      I repaired a similar one of these last week as it had a fluctuating output on the transformer so it was doing all sorts of things to the machine. The problem with these machine internals is they are using standard electronic components. Mixed with constant high temperatures and then throw in condensation and moisture, it's a recipe for disaster in terms of electronic components. I would personally like to see a high temp lacquer on these boards. All though that would make them harder to repair so there's no win >.<


      • #4
        I take it there are no schematics or trouble shooting info for these boxes?

        I need to fix a Bezzera BZ02 that is doing some weird things. Seems a waste getting an entire control box if only a handful of components need replacing on the board.



        • #5
          Originally posted by Talk_Coffee View Post
          Purchase a new one from Casa Espresso and bin the cooked one
          Originally posted by artman View Post
          Seems a waste getting an entire control box if only a handful of components need replacing on the board.

          My Thoughts exactly art man,

          I gave Casa Espresso a call but Antony(is that his name?) had just left for the US for 9 days or something so thought I would give it a go before putting in for a new one. If I can get a part for $10 rather than buy a new for around 150-200 then great, although I have now put $15 into it

          Anyway, here are more pics. I found a schematic and have included some bigger pictures of the AC and DC side of things.

          Another thing, the red LED doesn't light up. Don't think that has anything to do with anything but don't know what "p" is on the schematic.
          Attached Files


          • #6
            And here is pic of the front of the unit
            Attached Files


            • #7
              Here is a video of what is happening.


              • #8
                This is a bit hard for me to help online. I can usually fault the parts in a few minutes with a multimeter and a power supply. These are definitely worth fixing you just need some electronic knowledge I guess. I had a faulty PID controller on my Duetto and fixed it for $4 and 30-60mins work.

                Although, no electronic knowledge can equate to more destruction.

                Maybe send me a pm and we can see what we can work out for ya.


                • #9
                  Can you provide a photo of the capacitor on the board with the relays on it from the side? From the top it looks massively swollen, this would be at least one of the problems. If you've thrown parts at it without replacing that capacitor then you might have damaged them again or caused more damage.
                  You stated that you replaced R3 and it burnt out? What part of it burnt out? Contacts or coil? You'd burn a coil out if it has too higher voltage applied, may be the case if the capacitor is faulty but it seems odd. Check the output of the voltage regulator (small component next to the capacitor.) It's probably a 5V reg so if it's outputting more or less than its rated to then there could be problems. Give me the part number of the regulator. Probably starts with "LM". Somewhere around the 4th digit should indicate the voltage output.

                  The bridge rectifier and regulator are the 2 active components that can cause trouble. Everything else is pretty basic. I doubt you'd have a problem on the other board, it handles small signal information and is pretty reliable.


                  • #10
                    Thanks Noidle22

                    The contacts on the relay burnt out. The coil looked fine.
                    Ive attached a picture of the cap.
                    Ive also attached a picture of the bridge rectifier and regulator.
                    The rectifier is the round one right?
                    The regulator is reading about .3V DC.
                    The number on the side of the regulator is 7812CT

                    Thanks for your time,


                    Attached Files


                    • #11
                      Yea that capacitor is definitely faulty. Replace it then give it a go. Not sure why the contacts would burn out on that relay though. Are you sure you replaced it with a relay capable of 10A at 240V?

                      Yes the bridge rectifier is the round one. That's unlikely the problem but you can test it though if you have a diode test function on your multimeter. Make sure the box is disconnected from any power first. Test both ways across the legs marked ~ which indicate AC input. You should get no continuity either way. You should get continuity in one direction (of about 0.6V, standard diode junction) between one ~ and either - or +, the same for the other ~. If you test between - and + you should get about 1.2V in one direction and no continuity in the other. The 1.2V indicates 2 diode junctions.
                      Any readings aside from this indicate a faulty bridge.

                      LM7812 is a standard 12V regulator. You need to test this with the machine on otherwise the regulator wont function. Use the centre pin of the regulator as a ground reference or any other part of the circuit you know to be ground. One pin should read input voltage, somewhere between 15-20V probably, the other should read very close to 12V.
                      If you read anything other than 12V or close to it on the output then it's faulty.

                      Replace the capacitor FIRST then test the system and see, that might have been all that the problem is. Check that the relay that burnt out was the correct one. Be very careful if you decide to test with the machine powered up, there's live 240V in there when it's on.


                      • #12

                        Definitely the same relay. I was a little surprised to see the contacts burnt on it.
                        Ill order the cap tomorrow and give that a go and let you know

                        Thanks for the help


                        • #13
                          All fixed.
                          Thanks Noidle22, Brendogs and Artman for all the help.
                          Ended up costing $25 for 2 relays, a transformer and a capacitor + a little desoldering sucker tool thingy.
                          Heaps better than $160 for a new one.
                          It ended up being the Capacitor. It must have caused problems to the transformer and relay.
                          I think I have worked out how these things work now!
                          If anyone needs help, this is the place to come.


                          • #14
                            Great result, well done.

                            I live the satisfaction of fixing something successfully rather than binning it (and not mentioning the cost savings). Just wish I had more time ...

                            I need to fix a Bezzera bz02 volumetric. At the moment it just keeps filling the boiler until water starts popping out of the safety valve. The level probes are connected. Haven't had a chance to have a good poke around but will no doubt be back picking brains for info and ideas.



                            • #15
                              Yes, a very satisfying result.
                              Hopefully it stays fixed for a little while. Playing with solder is not my forte!
                              I haven't found why the capacitor gave way. Im hoping a power surge or something like that.
                              This oscar is so easy to work on and seems to be a simple design. Kind of reminds me of the morris mini I use to own as a teen.