Announcement

Collapse
No announcement yet.

Sunbeam EM6910 Dripping water from PF when steaming

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sunbeam EM6910 Dripping water from PF when steaming

    Hey guys got my EM6910 about 2 weeks ago here in the states (rebranded as a Krups machine). You all have been awesome for getting the perfect cup from this machine!!! Only issue I am having is that when I am steaming milk I notice the PF dripping water. It doesn't matter if I cleaned the PF out or if it's not in the group head I still get little drops every couple of seconds. Is this normal?

  • #2
    Originally posted by NuLLKiLL View Post
    Hey guys got my EM6910 about 2 weeks ago here in the states (rebranded as a Krups machine). You all have been awesome for getting the perfect cup from this machine!!! Only issue I am having is that when I am steaming milk I notice the PF dripping water. It doesn't matter if I cleaned the PF out or if it's not in the group head I still get little drops every couple of seconds. Is this normal?
    Hi NuLLKiLL

    I had 2 6910's until recently (only one at present). There are many "quite different" variations within the 6910 range, the 2008'ish ones (mostly) did this out of the box. A qn: is the "red button" on your drip tray round (circular / cylindrical) or a long strip connected by a lever?

    http://coffeesnobs.com.au/brewing-eq...tml#post507441 onwards has a lot more of my posts about 6910's and 480 grinders. Please read them before asking for things I have already written about: that is my actually first CS post...

    I presume your Krups is new? If so, not normal... FYI, no big deal in terms of usage, unless you froth a lot of hot chocs in the jug without pulling a shot.

    Regards

    TampIt

    Comment


    • #3
      My EM6910 seems to drip a bit of water whenever I steam too. I don't think much about it though.

      Comment

      Working...
      X