No announcement yet.

EM6910 pressure guage not working.

  • Filter
  • Time
  • Show
Clear All
new posts

  • EM6910 pressure guage not working.

    This seems to be quite a common problem with the 6910. Gumtree and Ebay frequently have secondhand Sunbeams advertised with comments to the effect that the machine works well but the pressure gauge does not give a reading.
    Recently I have repaired two machines with these symptoms and in both cases the problem was caused by a blockage in the same place - the vent hole in the brew head thermoblock which leads to the pressure gauge "T" and the solenoid valve.

    A close examination of the blockage site has revealed what is most likely the cause of the problem - a very narrow section at the internal bend where the drilled gallery meets the metal tube leading to the pressure gauge and solenoid valve. In a poorly maintained machine this point blocks solidly with oils and grounds and is very difficult to clear because it is so narrow.
    Because of the small size of the opening it is often difficult to get a piece of wire into it to clear it or it can take a lot of pressure and soaking with cleaner to blow it free, as well as the need to dis-assemble much of the machine.

    I have found that perseverance with a thin piece of stiff wire in this drilled hole can usually open it enough to get the cleaning solution moving through it without resorting to a major tear-down but it does take quite a bit of pushing and jiggling.

    It appears that this restriction is caused by a manufacturing flaw and I have been tempted to try carefully drilling it out but, without knowing how close it is to the internal heating element and spiral water tube, have thought better of it. If anyone has an old 'burnt out' thermoblock it would be helpful if they could carry out a post mortem on it with a hacksaw in this area to see if drilling would be a safe option as it would certainly keep a lot of these machines operating more reliably and out of landfill.

    I have attached some photos to help illustrate what I have been describing - one shows the plumbing in the thermoblock (please excuse the hi-tech labels but I was in a hurry) and the other is taken down the drilled hole with a light source shining in the side tube to show the very narrow opening.

    Click image for larger version

Name:	down the hole.jpg
Views:	1
Size:	40.8 KB
ID:	758004

    Click image for larger version

Name:	Thermoblock.jpg
Views:	1
Size:	71.4 KB
ID:	758005


  • #2
    Hi xanthine I have poked a thin wire about 1.5 inches into that vent hole and back flushed 3 times with no better result, would you recommend back flushing without the brew filter and shower screen out of the head and see if that works


    • Xanthine
      Xanthine commented
      Editing a comment
      ... could be worth a try. By "brew filter" I presume you mean the basket - this has to be in place along with a backflush disk, to build up pressure. Also, having the shower screen still ifitted helps to hold the seal in place.

  • #3
    Hi again, no i meant to keep the basket in place but take the shower screen out of the head, the reason was to by pass the screen and direct more water up the vent, i didnt do it though. I did push another wire further up vent but still no progress with gauge and no leaks and no back pressure issues when finishing coffee. thanks for the responses.


    • #4
      One one machine i had a look at the blockage was in the small copper pipe downstream that has two 90 degree bends. Had to take the small pipe off and unblock by lots of prodding etc and compressed air. Cheers


      • #5
        Hi Xanthine, sorry I missed your post and question on another thread, I missed updating, sorry about that(mid last year) can't find it now. It was about the 3 way valve not working. It was indeed the block in the little port you list in your first post here. It took a lot of persistence, I had even bought another brew thermoblock.

        I tried something I should not advertise, not best practice!!
        But I used and aggressive descale tablet, in the basket!
        Leroy said that is a no,no, and I understand why.

        However, it got the 3 way to start working, maybe more luck than good management, or good practice.
        So I kept on it with proper, but strong vinegar cleaning solution and all is good.

        Now on to another one with a blocked steam thermoblock.
        Vinegar solution got it going for a short time, but I suspect loosened some material not it is blocked properly.

        Very grateful to you and all the other posters on here.



        • #6
          Hi Rawill, Glad to hear you've been successful in getting your various 6910s going - it becomes a bit of an addiction doesn't it? Just when you think you have a handle on repairing these they throw a curve ball with some strange fault. All good fun though, especially if you have a spare machine to tide you through with coffee while you fix the other one without the stress of caffeine deprivation.