No announcement yet.

Flymax Junior

  • Filter
  • Time
  • Show
Clear All
new posts

  • Flymax Junior

    Gday Coffeesnobs. I have been playing around with a Flymax Junior, hoping to make it suitable for a friend to use. I purchased it quite cheap. I was glad to find that it has quite similar specs to the Lelit I have as I was initially concerned about parts. The 57mm porterfilters are almost identical, and drip tray is very similar. The internals are similar too but the Flymax has the addition of a dedicated aluminium(?) steam boiler.

    I fired it up and it worked fairly well but with a couple of issues:
    1. After I backflushed it with cleaner there was water dripping consistently from the shower screen.
    2. The lights didn't turn off to indicate it was up to heat.

    I have since taken the boiler out to pull apart to check inside but have found out difficult to separate the halves.

    Any insight on these issues would be appreciated.

    Boiler: Internals minus boiler:Boiler out:
    Last edited by Outbackstriker; 2 February 2016, 09:47 PM. Reason: Add photos

  • #2
    Would also be interested if anyone knew of a good steam wand replacement. The male thread seems to be 11mm:I actually made some decent milk with the plastic tip but it seems difficult to clean and looks tacky. I put the old Lelit tip on for fun... Now that is a mini wand:
    Here is info about the machine


    • #3
      G'day mate...

      If you google for a website called "Coffee for Connoisseurs" and then head to a heading called "Articles", you will find a number of links to very helpful pages. I would suggest you click on the one called "Lelit/Imat/Nemox Machine Repair" as that is likely to be the most helpful...



      • #4
        Thanks for the response Mal, I will check it out.


        • #5
          I believe I have finally diagnosed the first of these issues. However I have since discovered a more serious issue. The separate steam boiler, the rectangular silver one in the second pic, does not cease heating up! It has a 165deg thermostat and a safety one as well, not sure of temp. When tested with my temp multimeter the boiler went to 175deg and did not shut off. I swapped in a 125deg spare thermostat I had but boiler went to 150 when I manually turned it off. Also tried with a 140 deg thermostat and it again went way over. Anyone have an idea why this would be?


          • #6
            Just a couple of thoughts on this -

            Have you checked the accuracy of the meter used to measure this? If the probe is waterproof you could place it in boiling water to see if it reads close to 100 deg C.

            I searched the link you posted to the machine's website and it's certainly not very helpful (may have lost something in the translation!) so it may be worth contacting them for a manual or some further info.

            Have you checked the wiring to make sure that the thermostat and thermal fuse (I presume) are wired correctly in series with the heating element or is there a relay in the mix as well?



            • #7
              Thanks for the response. I only just had a chance to look at this again. The temp probe is definitely correct. I have tried to contact manufacturer through a number of different methods for more info but no response.

              I cannot see anything obviously wrong with wiring. Tested again and steam boiler temp went to 185deg and still climbing before I switched it off. Seems dangerous to me so I am just going to be wise and relegate it to spare parts.


              • #8
                I once thought my roaster was going crazy with temps suddenly reading MUCH higher than they should. Checked my multimeter only to discover it had switched itself to Fahrenheit, switching it back to Celsius set things right


                • #9
                  Originally posted by Vinitasse View Post
                  I once thought my roaster was going crazy with temps suddenly reading MUCH higher than they should. Checked my multimeter only to discover it had switched itself to Fahrenheit, switching it back to Celsius set things right
                  Thanks for the suggestion. Definitely Cels as I checked it with some boiling water.


                  • #10
                    Have you tried pulling one of the leads off the safety thermostat (thermal fuse or cutout?) and powering the machine up to see if it still heats up - just make sure you secure the loose lead so it can not short out.
                    You could possibly try this at different points in the steam circuit to track down the fault.
                    Also, could you please provide more details and possibly photos of the thermal switch and safety. I presume the 'white block' with red writing on the side of the steam thermoblock in the photos above is the cut-out. Can you see any sign of a temperature sensor on the steam thermoblock with wires connected to an electronic control board?
                    Senior Member
                    Last edited by Xanthine; 21 March 2016, 08:20 PM. Reason: Fix typo and more detail


                    • #11
                      Thanks Trev. Your suggestions have kept me going a little longer. I disconnected one lead at a time off each thermostat and it did not heat up at all each time. I looked for a control board earlier near the power cord but could not locate one at all. Below is a closer photo of steam boiler.


                      • #12
                        From what you have said and shown it certainly looks like the steam thermoblock temperature is only being controlled by a basic thermostat with no 'smarts' involved, so logically the heating element, thermostat and safety switch would all be wired in series . The steam pump is probably switched on as required to produce steam - is the steam production controlled by a tap or a switch?. Or could one of those switches you show be a pressure switch? Sorry about so many questions but with an unfamiliar machine it helps to understand how it works in order to diagnose the fault.
                        And one more - which of the two devices on the side of the thermoblock did you swap - the black or the white?

                        Could you perhaps trace out the wiring on the steam side and make a sketch of it?

                        P.S. Please make sure the mains plug is pulled before you poke around inside - obvious but easily overlooked.


                        • #13
                          Thanks again. The steam production is turned on by a switch which does start the steam pump. From what I can see once water enters the bottom of the thermoblock it forces steam out the top. It produces some quite powerful steam. I unplugged each of the thermostats. The black one would be the regular cutoff at 165deg. Cannot see the temp on the white one which I assume to be the safety. I will draw circuit when I get account chance to take a close look at it.


                          • #14
                            Oh and about the swapping. I swapped the black one for some other thermostats that I know are working. Always unplugged the power too!


                            • #15
                              Well if the black one switches off at 165degC and pulling its lead stops the steam heater it has to be faulty/inaccurate.
                              How is it mounted? - it looks like a screw-in stud mount.
                              Was the 125degC one new or pulled from something else? - could it also be faulty?
                              I'm trying to think of a way you could test them out of the machine but immersion in hot engine oil is pretty risky.
                              From the photo of the boiler it looks like you have another one there which is probably only 90 odd degrees - maybe you could temporarily swap this into the steam thermoblock and see if it controls it to a lower temp.
                              BTW, the white square one seems to have T250 written on it - could it be its trip temperature? This one and the other on the water boiler seem to have buttons sticking out of their tops which may be a reset.