Announcement

Collapse
No announcement yet.

Ohh Dear Miss Silvia

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ohh Dear Miss Silvia

    My beloved V2 with Watlow SD pid is out of order.

    All I know is now it no longer heats the water.
    I came home from work 2 days ago to the news that ur had been making a "bad noise" maybe vibrating, ticking or something like that.


    Suspect buggered element but would like to know the diagnosis if others have had the same happen.

  • #2
    You are dealing with 240 volts. The unit must be fully disconnected from the mains, not just turned off.
    I would be happier if you could take it to an electrician who could test whether there was a short circuit in the boiler terminals. The wires have to be unplugged from the terminals. On my photo one is a black wire the other a yellow wire. At this point the electrician will know how to test if the coils are shorting to earth or have an internal break. This at least will say whether it is a boiler fault.
    My Watlow is still working well.

    Comment


    • #3
      I've had mine not heat before. There is a red reset switch on the boiler inside. I was lucky enough that that got me going again and it wasn't my heating element

      Comment


      • #4
        +1 do the rest first. Do you know where it is?

        Comment


        • #5
          https://www.youtube.com/watch?v=qdJ3tM2fDb0

          There is pretty much a youtube vid for anything you want to do to a Silvia

          Comment


          • #6
            Originally posted by dumiya View Post
            You are dealing with 240 volts. The unit must be fully disconnected from the mains, not just turned off.
            I would be happier if you could take it to an electrician who could test whether there was a short circuit in the boiler terminals. The wires have to be unplugged from the terminals. On my photo one is a black wire the other a yellow wire. At this point the electrician will know how to test if the coils are shorting to earth or have an internal break. This at least will say whether it is a boiler fault.
            My Watlow is still working well.
            Thanks @Dumiya for the wires to test.
            My little sister is nearly done with her electrical apprenticeship should suffice as the technician, she will be paid in shots of coffee with milk as I have 'snobbified' her taste in coffee. To where I have to be on my A game with every shot pulled

            what about the brraaap type vibe ish humming noise it was making



            ps: missed(never got) the emails for your comments sorry

            Comment


            • #7
              Originally posted by JWILL View Post
              My little sister is nearly done with her electrical apprenticeship should suffice as the technician
              Unfortunately, unless the laws have changed, any work she does will have to be vetted by a licensed and qualified electrician. Perhaps her boss at work could do this for you...

              Mal.

              Comment


              • #8
                Hi, I'm new here but I thought i should warn you all, I've got a V4 Ranchilio Silvia. It started tripping the RCD and after much research, everything I read was rubbish!! Forget the test of the element, my element test came out exactly the same as the new element! If you have left the steam wand on the whole day, you can bet it's the element! It's $100 replacement on the V4 and later machines, not too difficult but don't trust the OHM reading test, if you think it's had an over heat, pull off the boiler and if the element looks crap, it is.

                Comment


                • #9
                  Pretty sure his Sister will figure all that out...

                  Mal.

                  Comment


                  • #10
                    keen to hear the outcome of this.

                    Comment


                    • #11
                      Thanks for the replys ended up with choofing it off to a shop and getting a clean from the scale due to the manky Perth water( has always been filtered though)
                      Back on CS cause it playing up again....

                      Comment


                      • #12
                        From the symptoms described in the other thread you started, it could be that a piece of residual scale has found its way into the 3-Way Valve and jammed it...

                        It's not a hard job to pull these down, clean and replace. Suss out Alan Frew's very helpful "how to" page on his "Coffee for Connoisseurs" webpage... You'll need to Google it.

                        Mal.

                        Comment


                        • #13
                          Originally posted by Dimal View Post
                          From the symptoms described in the other thread you started, it could be that a piece of residual scale has found its way into the 3-Way Valve and jammed it...

                          It's not a hard job to pull these down, clean and replace. Suss out Alan Frew's very helpful "how to" page on his "Coffee for Connoisseurs" webpage... You'll need to Google it.

                          Mal.
                          Will do that on the weekend thanks for the tip Mal.
                          James

                          Comment

                          Working...
                          X