Announcement

Collapse
No announcement yet.

EM6910 intermittent weak steam, short pump pulses

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • EM6910 intermittent weak steam, short pump pulses

    I have a 6 year old EM6910 and recently it's developed an intermittent fault with the steam wand. Half way through streaming a jug of milk the pump changes from its regular duty-cycle of around 0.5s on, 0.5s off, to a very brief pulse every second or so - maybe 0.05s on, 0.95s off. Steam pressure drops off, then after maybe 10 or 20 seconds it returns to the regular duty-cycle.

    Anyone got any thoughts on what might be causing the problem?

  • #2
    Originally posted by EdwardC View Post
    I have a 6 year old EM6910 and recently it's developed an intermittent fault with the steam wand. Half way through streaming a jug of milk the pump changes from its regular duty-cycle of around 0.5s on, 0.5s off, to a very brief pulse every second or so - maybe 0.05s on, 0.95s off. Steam pressure drops off, then after maybe 10 or 20 seconds it returns to the regular duty-cycle.

    Anyone got any thoughts on what might be causing the problem?
    Gday Edward,

    I have had this problem on both my EM6910 and EM7000. On both occasions it was scale from the steam thermo block creating blockages which seems to overload the pump. With the EM6910 in situ de-scaling the steam thermo block is not possible so I opened the case and disconnected the copper tubing and manually de-scaled the thermo block, and all plumbing using a syringe and de-scaling solution.

    This fixed the steam issue until I upgraded to the EM7000 only to have the same fault [emoji57] it seems it is definitely a known issue as the EM7000 has a cleaning cycle for the steam thermo block where the heating element doesn't turn on, meaning no disassembly required.

    I hope this helps

    Comment

    Working...
    X