No announcement yet.

Water is not pumping - Mokita Combi Super

  • Filter
  • Time
  • Show
Clear All
new posts

  • Water is not pumping - Mokita Combi Super

    Hi everyone,

    I am new to this group and trying to remember how to use my Espresso machine. I have had a Mokita Combi Super for about 10 years now. I have not used it in the last 5 years. I thought that I would remember how to use it but it seems not. I have tried to find a manual over the web but couldn't find any. And the only youtube stuff on that matter seems to be either from India or Thailand.

    The problem seems to be the water not being pumped. I thought that by using the steam valve I could get the water in the pipe but no water seems to be moving. When I open the valve, water come out of the wand no problem, but when I close it, no water comes thru the shower head (filter).

    Do I need to execute a particular set of things to do in a chronologic manner or do I need to change a part that might be broken (what pumps the water in the machine)? Please tell me what I should do step by step. LAst time I used it 5 years ago it seems to work just fine.

    Thank U on advance
    Paul (and Mary)

  • #2
    Hi Paul,

    First of all just a caution - if there is no water in the boiler and your pump really isn't working then turning the machine on for any length of time is likely to burn out the heating element.
    If there is any chance of this happening pack it up and send it off for service.

    There are two switches (brew switch and fill switch) that activate the pump.
    The fill switch will cause water to flow through the steam arm if the steam knob is open.
    The brew switch will cause water to flow through the group and the steam arm if the steam knob is open.

    With the the steam knob open, hit either of the switches.
    If water flows through the steam arm (not just dribbles) then your pump is working.

    Assuming water is being pumped, close the steam knob and hit the brew switch. This is usually larger and has a sort of arrow symbol near it.
    This should cause water to flow through the group.

    If not then there is possibly a blockage somewhere or the 3-way valve (which lets water through the group) could be stuck / not working.


    • #3

      Unfortunately, that's not correct s_u...
      The "Brew Switch" activates the pump and selects the "Brew Thermostat"....
      The "Steam Switch" does NOT activate the pump and selects the "Steam Thermostat".

      Selecting the Brew Switch with the Steam Valve Open, allows the water to run into the Boiler and is completely filled when water exits the Steam Wand. This procedure is used after every Milk Texturing session to ensure that the Boiler is never allowed to run dry and potentially burn out the heating element. It's called "Priming the Boiler".

      Given that water is being pumped through the Steam Wand when the valve is opened, it sounds as though the 3-Way Valve might be stuck closed. Taking the machine to a reputable service agent, as suggested by s_u, is highly recommended so that a full service and clean can be undertaken and perhaps a bit of one-on-one tutoring on how best to use the machine, to refresh the memory....

      All the best,


      • #4
        You've confused me now Mal, I'm going to go home and check.
        Mine is a Quaha and may be different to the Mokita slightly.

        But note, I wasn't talking about the steam switch.
        On mine, there are 3 switches, a steam switch, which does indeed change the thermostat and does not turn on the pump, as you suggest.

        Then there are 2 other switches which do turn on the pump.
        The first one I called the "fill switch" which I use to fill the boiler after steaming.
        Water doesn't flow through the group when I press this, which I assume just turns the 3 way valve completely off.

        The "brew switch" causes water to flow through the group, but water will also flow through the steam wand if open.

        I think we are on the same page.

        One possible issue was that Paul may have been pressing the "fill" switch instead of the "brew" switch.



        • #5
          HI everyone.
          Thank you for your kind answers.
          We gonna try that and we'll keep you posted in the next few days.
          Have a great day !


          • #6
            G'day Taan....

            I owned an Imat Mokita for a few years and none of the models I saw had a Fill Switch as such. May have been a Quaha speciality perhaps...
            Anyway, I think your advice to take the machine to a reputable specialist espresso machine service centre/repairer is the best thing to do. Shouldn't be any mix-ups then hopefully...



            • #7
              For what it's worth my old Nemox had the separate "fill" button also.

              Although these machines look similar they do have their differences. Some don't have a 3 way valve, the quaha have reversed switches (up for on), different steam wand fitting etc.

              They are a great and simple machine capable of a ripper brew.



              • #8
                Hi again Guys...

                I just dug out some photos of my Imat Mokita from a looong time ago, and you are all correct.
                There is a third switch for running the pump and NOT the 3-Way Valve although I don't think it was referred to as a Fill Switch on the Mokita but I'm probably wrong on that score too....

                Sorry for the misinformation...



                • #9
                  I don't think it was called a fill switch either, not really sure of it purpose, perhaps to get hot water out of the steam wand instead of the group for filling a glass for a long black?



                  • #10
                    I did make a mistake in my first post.
                    After looking at my machine, the switch with the arrow near it is actually the on/off switch (fourth switch).
                    The brew switch has a cup symbol next to it.
                    I am sure this wouldn't have confused the OP too much.

                    I did make up the name for the "fill" switch. That's what I use it for.
                    I never received a manual with my machine so don't know what the real name or purpose of it is either.

                    Good luck Paul, hopefully it is just something simple.
                    Good little machine if you can get it going.


                    • #11
                      It seems that the problem is the pump.
                      Thank you !


                      • #12
                        Originally posted by MaryPaul View Post
                        It seems that the problem is the pump.
                        Thank you !
                        For reference purposes, I recently looked at a very old machine that had been sitting idle for many years.
                        When I turn it on the pump made all the right noises but no water flowed.
                        It turned out that some sludge had built up (grown??) inside the pump blocking it internally and once it had come out the pump worked normally.

                        Is your pump making any noise when you turn it on?
                        If so it may not need replacing, however a little vibe pump is not that expensive anyway.
                        In either case a service centre will sort it out.
                        If you provide your location somebody here may be able to provide you with the name of a reputable local repair shop.


                        • #13
                          Yes, the pump is making noise and no water is being pumped from the tank to the pump (only vibrations-no water mouvement). Also, no water from the steam wand and smell of burning.
                          We are from Montreal, Canada.
                          Thank you again!


                          • #14
                            Time to turn it off and find a repair centre.
                            Most people here are from the Southern Hemisphere - any Canadians reading?
                            Montreal based Espresso Machine Service and Repair shops?

                            May be worth posting on HomeBarista or CoffeeGeek which have a higher percentage of North American readers.


                            • #15
                              It may be worth checking the line from where pump draws its water to the water tank. I have seen with some machines where the water tank is removable and has a spring loaded valve to stop it leaking while filling. I had the same problem as you and eventually figured out the little valve was not opening properly when the tank was inserted, and so the pump could not draw water. If you can open the machine and replace the line on the negative side of the pump with a piece of hose and see if it draws water out of a container this will be a good diagnoses of pump status!