Announcement

Collapse
No announcement yet.

EM6910 no water pushing through

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • EM6910 no water pushing through

    Hi all

    I've pulled my trusty EM6910 out of storage from sitting around for a few years. Started it up to run some water through it before using it again however no water is coming out of the group head or water wand. The steam wand appears to work however seems to be a bit weak.

    Any ideas what is causing the issue at all?

    Thanks

  • #2
    Did a bit more digging around, when I disconnect the top brass connection to the water pump (red unit) and run the manual button no water is pushing through, however pump is making the usual loud noise (possibly because its dry). Does this mean the pump is faulty or a part of it.

    Comment


    • #3
      Open the steam and hot water knobs at the same time and wait. This should prime the system. Once you get steady hot water flow and steam then you should be good to go.

      If after 30 seconds or so there has been no improvement or only some steam coming from the hot water wand instead of water, remove and install the water tank a few times in quick succession. This can assist to force a bit more water into the lines.

      Comment


      • #4
        Thanks tried all that, still no go after having the steam and water knobs on for a period of time. Nothing looks out of place however Im guessing there is a blockage or failed pump / part in there somehwere

        Relegated to spare parts I think.

        Comment


        • #5
          What's your location tez1?

          Comment


          • #6
            Sydney. I've already pulled some of it apart looking at it - and havent really put it back together. Do you need a bit off it?

            Comment


            • #7
              Depending on how stuck you get I might be able to lend a hand fixing it. I have a few spare parts for those lying around. Though I'll never turn down more!

              Comment


              • #8
                I had one which had been in storage for quite some time with water left in the clear plastic water lines. All sorts of slimy organisms grew in them and ended up blocking the jet in the flow sensor. It took quite a bit of work to get them clear and included pulling the top off the flow sensor to clear it.

                Comment

                Working...
                X