Announcement

Collapse
No announcement yet.

Rusty and/or corroded E61 Mushroom

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Rusty and/or corroded E61 Mushroom

    Hi

    For the first time in 3 years I decided to take a look at my Isomac Tea mushroom for signs of scale. Apart from the first three months of use the system has been on a reverse osmosis filter system. To my surprise the shroom had a lot of corrosion and what looks like copper scale. Firstly, is this normal? Secondly, given that my system is plumbed in, how do I go about descaling it?


    Cheers

    Fil
    Attached Files

  • #2
    for 3 years worth of use, that doesnt look too bad !
    so , yes, i would suggest that is "normal"
    sorry, cant help with suggesting a descale procedure for a plumbed m/c, ....other than using the tank procedure but feeding your pump from a temporary tank (bucket ?) with the descale solution in. ?

    Comment


    • #3
      Mine looked worse than that and I thought it was fine. Those deposits are really quite small.

      That said when I descaled the machine.. wow what a difference.

      Comment


      • #4
        Descaled using the Sunbeam tablets. Problem with the Tea is that the pump seems to need positive pressure once its been hooked up to mains. Anyway, let it sit for 45mins and flushed it through. All the scale is completely gone and the chrome plating has also gone from most internal surfaces in the head leaving beautiful pink copper. No wonder the e61 head is so expensive!
        I would have thought the RO water would have completely negated using a descaling solution due to the almost 100% lack of dissolved solids. Thoughts?


        Cheers

        Fil

        Comment


        • #5
          Did you consider talking to the people you bought it from for descaling advice? And what product to use?
          And as for the RO water, was this a decision made with advice that it would prevent scale?

          I sure as hell wouldn't consider using Sunbeam tablets on my Expobar (my mushroom still looks pretty good 6 years in), but that's just me.

          Comment


          • #6
            Yer rang them up and they just said to use any commercial descaling solution to get rid of heavy scale (ie lumps of it like mine had). The sunbeam stuff is the same as any other descaler as far as ingredients go (they actually list it on the package).
            As far as the RO goes, it was initially bought for salt water aquarium, then moved in as our main drinking water as Adelaide water tastes like what I presume a dogs anus would taste like. Given that the last TDS measured was 3 ppm I would assume that the scale came from the time when I was just using tap water for 3 months.
            As far as the internals relieving itself of the chrome plating, Ive read on a few other forums that its common. Given that this was already occurring just from the scale I can't see how it was going to be avoided.


            Fil

            Comment

            Working...
            X