Announcement

Collapse
No announcement yet.

No flow through grouphead

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No flow through grouphead

    Hi folks,

    I'm just wondering if anyone can help. I'm not getting any flow through this grouphead. Here's a picture of it - can anyone suggest what's wrong with it? Cheers.

    Click image for larger version

Name:	ImageUploadedByTapatalk1449917954.235071.jpg
Views:	1
Size:	343.1 KB
ID:	758226

  • #2
    Scale.. and heaps of it

    Comment


    • #3
      Looks fine to me, try grinding a little coarser.

      Comment


      • #4
        Hello Leroy,
        I would suggest you've uploaded the wrong image,regarding your question "what's wrong with it".
        Show the photo of the cleaned up group head together with a couple of different angle shots to make it less like a "quiz".
        Cheers,
        Mick.
        Using fresh water ( filtered) tank water ,this newer happens......no calcium...that's why.
        Last edited by mulquemi; 13 December 2015, 12:38 PM. Reason: Another thing!

        Comment


        • #5
          Leroy is a seasoned fisherman

          Comment


          • #6
            Originally posted by kyeba View Post
            Leroy is a seasoned fisherman

            They're not exactly running hot though are they? Just a few nibbles.

            Comment


            • #7
              I was thinking of the amount you got in such a short period. Tv fishing quality.

              Comment


              • #8
                Originally posted by kyeba View Post
                Leroy is a seasoned fisherman
                That explains the barnacles growing on his equipment. Perhaps he mistook it for an anchor

                Comment


                • #9
                  Maybe I can contribute some actual advice on this thread and bring it back on track......

                  First things first, have you tried turning it off and back on?

                  Comment


                  • #10
                    Originally posted by noidle22 View Post
                    Maybe I can contribute some actual advice on this thread and bring it back on track......

                    First things first, have you tried turning it off and back on?
                    OMG! Why didn't I think of that before I pulled it apart?!! Next time it'll be 1800-NOIDLE before I do anything! ROFLMAO!

                    Comment


                    • #11
                      Originally posted by magnafunk View Post
                      That explains the barnacles growing on his equipment. Perhaps he mistook it for an anchor
                      There's no barnacles on my equipment thank you very much.

                      Comment


                      • #12
                        Originally posted by kyeba View Post
                        Leroy is a seasoned fisherman
                        You need a dedicated fish cleaning bench to keep the scales out of your nice coffee gear though.

                        Comment


                        • #13
                          Haha...

                          Looks like the inside of a miniature Salt Mine mate...

                          You do realise salt can be obtained more easily than this; no need to bring buckets of salt water home from your fishing trips and make your own...

                          Mal.

                          Comment

                          Working...
                          X