Announcement

Collapse
No announcement yet.

help!! giotto not heating and no pressure.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • help!! giotto not heating and no pressure.

    hi everyone. i have got a problem and i someone can help. i was trying to descale my ecm giotto premium and following instuctions. i unplugged the boiler water level sensor and filled the boiler but water didnt come out of the opened steam wand and it wasnt making that sound it does when filling the boiler. i turned it off and on again and the emergency cut off turn off (tripped the breaker) so i pressed that little red button turned it off and connected the boiler water level sensor then turned it on again. it filled up the boiler but now the steam pressure is not going up and it doesnt seem to be heating up. i can pull water from the group head but not from the hot water tap and it doesnt seem to refil the boiler.
    what have i done. HELP!!

  • #2
    Re: help!! giotto not heating and no pressure.

    Originally posted by 6C6E6478313136010 link=1257576629/0#0 date=1257576629
    hi everyone. i have got a problem and i someone can help. i was trying to descale my ecm giotto premium and following instuctions. i unplugged the boiler water level sensor and filled the boiler but water didnt come out of the opened steam wand and it wasnt making that sound it does when filling the boiler. i turned it off and on again and the emergency cut off turn off (tripped the breaker) so i pressed that little red button turned it off and connected the boiler water level sensor then turned it on again. it filled up the boiler but now the steam pressure is not going up and it doesnt seem to be heating up. i can pull water from the group head but not from the hot water tap and it doesnt seem to refil the boiler.
    what have i done. HELP!!
    Generally if a machine trips your power, its a dying element and it will test with infinite resistance. If the thermal reset hasnt helped and the element tests at ~44ohm with the machine switched off and unplugged, sounds like an element relay to me...This requires a new control board and $$$

    Chris

    Comment


    • #3
      Re: help!! giotto not heating and no pressure.

      hi chris, thanks for the quick reply. how can i know if it is indeed the element relay? can i bring it to you tomorrow to check?
      thanks again

      Comment


      • #4
        Re: help!! giotto not heating and no pressure.

        if all of the other things test ok moey, it will be the element relay.

        You will hear a click when you switch the machine on, but it wont heat...

        Depending on model of Giotto, it can be board or board + wiring loom.

        Sunday is a day off for me

        Chris

        Comment


        • #5
          Re: help!! giotto not heating and no pressure.

          hi chris, when i turn it on i dont hear any click. the green light comes on but the machine is silent. no pump sound or anything. if it is the relay would that only stop it from heating or would it also stop the auto refil from working. water comes out of the grouphead but i cant get it to refil. it has descaler in the boiler so how can i flush it out? would it be bad to leave it in the boiler until monday?
          is monday ok for you? anytime after 3:30 pm if possible.
          thanks

          Comment


          • #6
            Re: help!! giotto not heating and no pressure.

            just wanted to say that my problem is now fixed. it turns out that the heating element died on me but once again (as seems to be a recurring theme on this forum) Chris from talk coffee has saved the day. i went down to see him and he had me back on my feet in no time. ;D
            thanks chris youre a great help and a real gentleman.

            Comment

            Working...
            X