Announcement

Collapse
No announcement yet.

Troubleshooting Unico Splendor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Troubleshooting Unico Splendor

    Hi All,
    Just purchased a second hand Unico Splendor for the office. Seemed like a good deal at the time - however- when I turn it on the pump starts and just keeps on pumpin'. It seems to be pumping water straight back into the reservoir. Is there something simple I am overlooking? Maybe something from the machine being stored or transported? Or is this job for an expert? The machine otherwise looks in overall good condition. I haven't contacted the seller yet - still hoping it's something simple.
    I think I may have read something about this issue recently but of course I wasn't able to find the discussion. Cheer, Daniel

  • #2
    Did you see it working before purchasing?

    Sounds like an OPV problem.

    Comment


    • #3
      I didn't see it working before buying. The machine was dropped off at my home - I didn't get a chance to try it out until the next day. I actually don't know any history of the machine at all. If it's not something simple - just like to arm myself with some info on what's possibly wrong before contacting the seller. Cheers, Daniel

      Comment


      • #4
        Agreed with TG, will likely be easily rectified. As the machine is somewhat of an unknown, it would be prudent to have a tech look at it, service anything that needs doing and then give it a clean bill of health. We're not able to take on any more work this week, but I'd highly recommend Rick Bond The Coffee Machinist who does superb work.

        Comment


        • #5
          Thanks guys, will send it in for a servicing. Any recommendations for the Eastern side of Melbs? Mt Waverley to Knox area? Cheers, Daniel

          Comment


          • #6
            I can only repeat Chris' recommendation and advise you to contact Rick @ Coffee Machinist.

            Good machine techs are thin on the ground in most places ..... but not at Northcote!

            Comment


            • #7
              Dropped the machine off to Rick today. Fingers crossed it's nothing too expensive!

              Comment


              • #8
                Picked up the Unico Splendor today from Rick. The machine was in overall pretty good condition. He did a full servicing changed a few seals and pressurestat - . The main culprit that was keeping the pump running was the group microswitch - so I'm lucky it was just an $18 part that was broken and I still got a bargain!!! Thanks for your recommendation.

                Comment


                • #9
                  Good outcome Daniel, well done.

                  Comment

                  Working...
                  X