Announcement

Collapse
No announcement yet.

Giotto sort of dead!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Giotto sort of dead!

    Hi all.

    Any advice is appreciated.

    A few months ago, my giotto wouldn't warm up. Just pulled cold shots.

    Changed the control board and been running perfectly since. ( Wiring mod done also)

    Today, I turned it on and it heated up fine.

    After about an hour I noticed the pressure started to drop on the gauge. No one touched the machine.

    Tried pulling a shot and nothing. No pump noise.

    Turned it off and left it for a while.

    When I turned it back on, pump started and wouldn't stop.

    Any suggestions?

    Cheers.

    Jim

  • #2
    Just some more info.

    When the machine cools down, I can pull a shot.

    The group temp sky rockets very quickly and the mechanical pressure valve on the boiler activates.

    After that, it's like a thermal cutout happens and I can't pull a shot.

    The pressure gauge doesn't move from 0 during this process.

    Thx

    Comment


    • #3
      Hmm. Hard to tell exactly whats going on, but board related for sure. Sounds like it could be overfilling the boiler, and water may be in the electrics if the safety valve has blown. I would discontinue use and find a tech!

      Comment


      • #4
        There is no water in the electrics as I have the machine apart. It almost reacts like when the reservoir has emptied. I'm pretty sure the boiler is empty. That's why the group is heating up that quick.

        Comment


        • #5
          If you have the machine dismantled, remove the vacuum valve and use a probe to see if the boiler is empty. I think it needs a service. The machine is worth fixing properly before something major happens. Bit of a nuisance.

          Comment


          • #6
            Originally posted by coffee_machinist View Post
            Hmm. Hard to tell exactly whats going on......I would discontinue use and find a tech!
            Good advice.

            Comment


            • #7
              Ok. So it seems the boiler is not filling with water. Pump still works and pulls shots until it thermally cuts out. Any ideas?

              Comment


              • #8
                Sounds like a dodgy element relay or pressurestat and a faulty autofill circuit. This could be as simple as a poor connection between the autofill probe and the control board or a dirty probe causing the autofill problem.
                Element relay could be sticking on, or the pressurestat. I've seen Giotto control boards with faulty small signal transistors, there's usually 3 of them, that can short or go open circuit. Cheap and easy to replace.

                Probably best to get it to a technician for a proper assessment as it sounds like there's a few funny things going on.

                Comment


                • #9
                  Mate, your machine needs expert attention. If you have the symptoms in front of you but don't know how to proceed, you might be causing further damage, eg burning out the element. Any remote diagnostics is guesswork and conjecture, a multimeter and experience are required at this point.

                  Comment


                  • #10
                    mate, when i descaled my machine the last time, i had the same issue. Would turn it on, pump would kick in but didnt stop, but no water getting into the boiler.
                    I disconnected the element, as didnt want it to burn out, then tried it a few times again.

                    i knew it wasnt the boiler water probe as i had just recently changed it, so went on to check all hoses and pipes for maybe any blockages.

                    after pulling hoses off one by one and checking that water was passing through, i finally tracked it down to one of the ball valves, or non return valve, where the water was not passing through. Cleaned it all up and all was good again

                    Comment

                    Working...
                    X