Announcement

Collapse
No announcement yet.

Nuova Simonelli Musica pump issue?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Nuova Simonelli Musica pump issue?

    My new Musica is acting strange. When pulling shots, no matter the grind fineness and bean age, the initial pull, before the espresso starts flowing, is taking about 15 sec. and i can not bring this time down, what so ever. The pump sound like there is no resistens in the PF and not building up pressure before long in the extraction.
    Is this a defect pump or the OPV thats acting out?

    Link of a pull, showing the issue.
    https://youtu.be/Z5PIfqq24FY

    Best regards, Christopher.

  • #2
    What's your rate of flow through the group with no PF in place?

    Comment


    • #3
      Thank you for the fast reply.
      The flow of water is fast and steady, after the flush.
      I have yet to measure it, but it seems normal.

      Comment


      • #4
        The flowrate could be a bit slow actually, compared to what i used to be before i had this issue.

        Comment


        • #5
          Originally posted by StopherB View Post
          The flowrate could be a bit slow actually, compared to what i used to be before i had this issue.
          Run water through the group into something for 30 seconds then tip it into a measuring cup (or run it straight into a measuring cup). Knowing the flow rate in millilitres/minute won't necessarily solve the problem but it could help narrow things down a bit. If the flow is restricted then there could be a blockage somewhere (usually in the 3-way solenoid), or there could be a faulty part (usually the 3-way or OPV). Have you done a back flush or descale recently? Do you only use filtered water?

          Comment


          • #6
            Hello Christopher. Welcome to CoffeeSnobs.

            It looks like low pressure pre infusion to me. Look in your instruction book to see how to adjust pre infusion if you want to. How does your coffee taste? Thats the main test.

            Barry

            Comment


            • #7
              I backflush daily. It's only 5 weeks old, and I use filtered water, so I don't think scale is the issue.

              Comment


              • #8
                Thank you.
                All the pre infusion features is turned off In the video. When making longer extractions then shown, it often tastes bitter and burned. The shot in the video is underextrated and tastes not very rich.

                Comment


                • #9
                  Originally posted by LeroyC View Post
                  Run water through the group into something for 30 seconds then tip it into a measuring cup (or run it straight into a measuring cup). Knowing the flow rate in millilitres/minute won't necessarily solve the problem but it could help narrow things down a bit. If the flow is restricted then there could be a blockage somewhere (usually in the 3-way solenoid), or there could be a faulty part (usually the 3-way or OPV). Have you done a back flush or descale recently? Do you only use filtered water?

                  I was trying to measure the flowrate, with no pf inserted, after about 15 sec. no water came out, and the pump went off after about 25 sec! It seems like it is broken.

                  Comment


                  • #10
                    Sounds like you better get in touch with the shop you bought it from.

                    Comment


                    • #11
                      Hi Christopher,

                      Didi you solve the problem with Musics. I am in the way to buy one, because I do believe that it should make better espresso than E61 machine can. Would you recommend me this machine for home?.Thank you! Petar

                      Comment


                      • #12
                        Originally posted by prusev71 View Post
                        I do believe that it should make better espresso than E61 machine can...
                        Welcome Petar,

                        I must say I am very curious to hear how you have arrived at that conclusion....

                        Comment


                        • #13
                          The Musica is capable of making excellent espresso, but I don't believe it is any better than a E61 machine. I have owned one for several years and find that it is easy to produce excellent espresso. It is possibly easier for unskilled people to use due to the controls. However I don't believe it has the finess of the Lever machines. Matched with a good grinder and fresh beans you can make espresso with either machine I am happy with my Musica but upgraditis is beginning to raise it's head :0

                          Comment


                          • #14
                            After watching the video, I always get about 5-6 streams of water through the bare group head when I flush it. Never do I get a single stream. Your pour rate is a bit fast. When your pump shut down did you have sufficient water in the tank? Check you shower screen is intact. If you have sufficient water in the tank and it is not pumping water take it to a repair person.

                            Comment


                            • #15
                              How old is your Musica? I have an older one on my bench right now and it has a ridiculously complex and unadjustable OPV/bypass system that's factory set.

                              I'm pretty sure the newer ones don't use a similar system. We would need to have a look inside to see where the water goes after the flow meter, pump and ... where does it go next?

                              Comment

                              Working...
                              X