No announcement yet.

Adventures in VBM Domobar Junior controller (AKA Gicar "LIVELLO PIC DELUXE") repair

  • Filter
  • Time
  • Show
Clear All
new posts

  • Adventures in VBM Domobar Junior controller (AKA Gicar "LIVELLO PIC DELUXE") repair

    MODNOTE: Not sure if this is the most appropriate location for this as although it refers to a "Pointy end" machine it's more about electronics than anything else.

    Apologies in advance, this may be a bit rambly, and will likely not mean a lot to anybody without some electronics knowledge.

    So a few weeks ago we had our (one for the whole house) RCBO trip a few times "randomly", this is not an infrequent occurrence as the normal leakage of the gear in my study is quite high, but it occurred two days running which was unusual, so warranted some investigation.

    Eventually figured out that there was some water pooling underneath my VBM Domobar Junior, pulled the main cover off to see what the source of the water was, and found that my anti-vac valve was dumping substantial amounts of water at startup and drenching the top of the boiler, which appears to be the cause of the RCBO tripping.

    Initially thought the anti-vac valve was stuck, so powered up again holding the valve closed, no leak. Ran it without issue for a few days then we had another power drop, and we were back to tripping the RCBO and this time the unit was behaving generally erratically (pump running continuously on one occasion, element relay pulsing on and off every few hundred milliseconds on another, generally erratic...), so I decided it was time to jump back in and investigate.

    This time I noticed what looked distinctly like a scorch mark on the Gicar controller and so the saga begins;

    Click image for larger version

Name:	IMG_5989s.jpg
Views:	1
Size:	133.0 KB
ID:	758243

    This sort of thing generally tends to suggest something inside got REALLY hot, at this point I confirmed that it was out of warranty, and given the price of replacements I decided to pull the controller and have a go at it myself (I'm a qualified EE).

    I pulled the guts out of the controller to check it out, "unfortunately" the controller was 100% pristine, no evidence of any damage and no evidence to suggest that the "scorch" mark was anything to do with the controller internals (no markings on the inside of the casing, no damaged components), the only thing I can think of is that they use thermal paper to print their labels and that end being the end which "points" at the boiler it got hot enough from radiant heat to discolour.

    Time to actually test the controller. First rule of electronics troubleshooting "thou shalt check power rails".

    The controller has two power rails, there's a 12V rail which drives the relays, and a 5V rail (derived from the 12V rail) that drives the microcontroller (PIC16F627) and all the other interface circuitry.

    The 12V rail read 9.5V so I back tracked and checked the output voltage of the transformer, it was ~18VAC which is reasonable for a lightly loaded, unregulated 12V transformer output. Swapped out the 7812 voltage regulator and checked again, no change, typically this suggests something "downstream" is pulling the rail low.

    Conveniently enough the Microcontroller is socketed (Gicar are also kind enough to provide an ICSP header if you should be so inclined), so I popped that out to isolate most of the circuitry in the controller. Rails were still low and nothing was getting hot (things that pull rails low will generally get hot as they are dissipating more power than they should be). At this point I basically concluded that the low rail must've been some kind of intentional design choice, perhaps a deliberate attempt to lower the power dissipation of the controller, since it's a rather tight envelope. The relays were still happily able to switch on the 9.5V provided by the 12V rail, and 4.5V (the 5V rail was low due to the 12V rail being low) is well within acceptable limits for the PIC micro.

    While the micro was out I had a poke around the socket to confirm I could fire all the relays OK, also the buzzer so it seemed that everything in the controller (other than the micro itself) was hunky dory, which suggested that the micro must have been the problem.

    Gicar of course are not going to give you the firmware file for their controllers, and as such if the micro is dead you've got two options, either buy a whole new controller, or write your own... Being that it's based on a PIC micro and a boiler auto-fill is not the most complex thing on the planet to implement I decided I'd go with option 2.

    The first step in that option was to reverse-engineer the whole damn controller, the result of that is the full schematics in the attached PDF. These are complete board schematics for the two boards in the controller, including unpopulated parts, the values for the SMD capacitors in there are largely stabs in the dark based on experience (small SMD caps generally don't have value markings on them), where I was unable to make an educated guess I labeled them ??nF. A point to note is that the Buzzer and the strange 2-pin connector (diagnostics of some kind maybe?) on the controller aren't really part of the "full" design (they're using holes which are intended for other things in other versions of the controller) and as such I didn't include those. For reference the buzzer's + terminal connects to FA11 and the - terminal connects to FA12, and the strange 2-pin connector is pins 3 and 4 of CN3.

    Now that I knew what was connected to where on the micro, it was time to try to characterise it as much as possible within the erratic functionality it was providing, I got some way through this work when I happened to poke the power rail with my Oscilloscope...

    Click image for larger version

Name:	Power.png
Views:	1
Size:	3.7 KB
ID:	758242

    That ain't right... 100Hz tells me it's mains related, so back to the power supply, filter caps looked fine, tested the diode bridge, it checked out, replaced it anyway in case it was some odd on-load type issue, no change.

    Next step, feed 15V from a bench power supply to the input of the 12V voltage regulator, et. viola, stable controller... Move it back to the input side of the bridge, still working A-OK, pulled out the filter cap to see if it'd ruptured on the bottom, looked fine, tested it with the meter and it was reading WAAAAAAY low, replace with a nice shiny new Nichicon cap from my stock and it looks like we're back in business.

    I'll throw it back in the VBM over the next few days and with luck I'll be able to move the ISOMAC Zaffiro back to the garage and push my single-boiler management mojo back to auxiliary storage
    Attached Files
    Senior Member
    Last edited by jbrewster; 19 December 2015, 10:55 PM. Reason: Broken Link

  • #2
    Nicely done Jb...



    • #3
      UPDATE: Controller's back in and behaving itself, but it looks like I still need to replace my anti-vac valve, it appears that it's not seating correctly. Progress though


      • #4
        That is assuming I can get the damn thing out...


        • #5
          Great work on the EE side, but for the mechanical side - you need an impact tool. I used a pair of vice grips to hold the fitting and whacked the spanner with a 'hammer' on a colleague's isomac to free the valve It seems coffee machines understand violence At home I would have used the air impact... The threadseal was rather over spec, IMHO!



          • #6
            Originally posted by KJM View Post
            Great work on the EE side, but for the mechanical side - you need an impact tool. I used a pair of vice grips to hold the fitting and whacked the spanner with a 'hammer' on a colleague's isomac to free the valve It seems coffee machines understand violence At home I would have used the air impact... The threadseal was rather over spec, IMHO!
            Thanks for the tip, I've not had a chance to get back to it as yet.

            The problem is that the anti-vac valve is in the right hand side of a tee, the left hand side of that tee is threaded into the boiler the boiler side is comparatively loose so when I attempt to turn the anti-vac valve the whole lot turns, I disconnected the steam wand line for fear of fatiguing it and breaking the tube, but I still can't get any sort of leverage on the anti-vac. I suspect I'm going to have to pull the water level probe gland then unscrew the entire tee and stick it in a vice so I can have at it.


            • #7
              I bought a pair of pointy nosed vice grips specially to do battle with the tee on the top of the NS Oscar. I was afraid of bending the metal on the boiler - it was in so hard. In the end I used the impact approach - had a spanner on the Tee, had someone hold the vice grips like grim death and hit the end of the spanner with a big hammer - just to be sure. One big whack and it came loose. No matter how much effort I put in on the spanner, it wasn't shifting, but the impact force worked a treat. My colleague was horrified when I used a hammer on her Isomac though
              I put in my mandatory plug for Loctite 567 as the appropriate threadseal when you put it back together



              • #8
                hmmm, Vice Grips might be doable, I'll have to have another look in there, I'd rather not have to take the water level gland out if I don't have to.


                • #9
                  Finally got back to this last week (couldn't justify spending the money on parts and stuff to fix the anti-vac when I had a functional espresso machine, but had some extra $ come in so I figured it was time).

                  Ended up taking the tube that connected the tee to the steam wand off altogether then sticking a screwdriver shaft into the arm that was connected to (geometry worked such that the screwdriver rode on the "throat" of the fitting not the opening, so no major risk of damage), then using a breaker bar to pop the old anti-vac loose, screwed in the new one (plus a healthy helping of Loctite 567) then ran it for a few hours with the cover off, had to tighten one of the flares to the steam wand, but otherwise all good and she's now up and running again.

                  I assumed that I must've had some scale preventing the old valve from seating, pulled it apart to check, turns out that wasn't the issue, the valve in it has an o-ring on which seats on what appears to be teflon seat, the o-ring appears to be pretty standard buna-n which seems a bit odd in a high temp application, in any case, whilst there was a bit of scaling, it mainly wasn't seating properly because the o-ring was "crispy".


                  • #10
                    Wow, has it been that long...

                    Shortly after putting it back into service (the day after IIRC) the RCBO was tripping again, so the Zaffiro has been sitting on the coffee bench since.

                    I finally found some time to get back to the Domobar Junior, powered it up in the garage (on my nice, shiny new, properly designed and installed electrical plant) and it instantly tripped the circuit's RCBO (not unexpected), disconnected the element and tried again, no surprise at all when the machine powered up without issue, so evidently it's the element that is the problem.

                    Pulled the boiler to extract the element, after some exertion and a bit of swearing I cracked the element loose, and this is what I found;

                    So it appears that during the controller fault the element was running uncovered for quite a while, yes those are blobs of melted copper.

                    Possibly a one-two punch combo between the faulty anti-vac valve preventing the boiler from sealing (preventing the pstat from doing its job, and also providing an exit path for water vapour) and the controller running the element inappropriately which allowed the boiler to boil dry (checked the water level probe, it's well above the top of the element).

                    Strange that there was a delay before it started tripping, all I can think is that it took a while for the moisture to get through the ceramic core of the element.

                    New element and gasket en route from Coffee Parts, once they arrive I'll put it back together and then it should finally be able to take its rightful place on my coffee bench.
                    Senior Member
                    Last edited by jbrewster; 11 June 2019, 11:17 AM.


                    • #11
                      New element installed, prior to connecting it I (over)filled the boiler and pressurised it under pump pressure to check for leaks.

                      That pesky steam tee that gave me issues earlier was leaking at the base and the water level probe gland was leaking so I pulled the boiler again had to remove the pressure relief valve, and the entire water level probe gland to get the steam tee out.

                      Re-fitted the steam tee, this time with a copper crush washer under it to enable me to get it properly oriented (originally an excess of teflon tape had been used to achieve this, but that presumably got displaced by the earlier misadventure with that tee (thus the leak), and a copper washer or similar is probably a "more proper" way to do this in any case) and a healthy dose of Loctite 567.

                      I'm not sure how the gland ever didn't leak (if indeed it didn't, might have been minor enough leakage that the water flashed off the top of the hot boiler and I was only seeing it because I was pressurising it cold), as it has what appear to be parallel threads and no thread seal, reassembled with a whiff of Loctite 567 on the "inner" part part to provide thread sealing.

                      After all that was sorted I also reinstalled the pressure relief valve and stuck the boiler back in, cold testing revealed no leaks (except the part where I wasn't paying attention and I pressurised the boiler past the pressure relief valve threshold and promptly drenched the boiler...)

                      Moved on to testing "hot" by reconnecting the element, but it seems I may have overtightened the pressure relief valve and warped the valve seat (there's not much material between the valve seat and the threaded boss) a bit because it is starting to vent (though not very much) just above 1 bar on the boiler pressure gauge and I gather they shouldn't open until somewhere in excess of 1.6, I'll re-fit it (with less gronk this time) and see how it goes, but I might have to order a replacement...

                      There's also seemingly been some weird intermittence in the boiler auto-fill (which given our prior meltdown I am of course eager to resolve), it has worked perfectly every time when I pull the controller out and test it on my bench but when I put it back in, on a few occasions with the boiler completely empty it wasn't filling even with the probe disconnected. Might be some issues with the probe/probe ground wiring as they got well and truly baked during the badness. I did replace the damaged parts of the wires with "proper" high-temp silicone wire, and there's no evidence of damage elsewhere on the wires so I'm not sure... I haven't had any issues through several cycles with a part-filled boiler. Might replace both wires completely "just in case" and do a bunch more testing before I declare it fixed.
                      Senior Member
                      Last edited by jbrewster; 20 June 2019, 05:14 PM.


                      • #12
                        Everything seems pretty OK since re-fitting the relief valve, and my high-temp silicone wire is in so I'll install the new probe/probe ground wiring tonight and spend some time soak testing tomorrow.


                        • #13
                          Excellent thread here. Love to hear of electronics getting a second chance at life.


                          • #14
                            The saga continues, so I was able to get into the situation where the auto-fill wasn't running even though the water level in the boiler dropped below the hot water dip tube (which is still slightly above the level of the element but it's a good gauge point), seems it was sitting *JUST* barely on the limits of what causes an auto-fill (oscilloscope seemed to bear this out being that I had about a 2.5V square wave on the boiler probe when the issue was occurring), backed the boiler water level probe out about 1.5mm, steam is still dry enough, and hopefully that should avoid the possibility of a recurrence and not throw the HX off too much.

                            Unfortunately the steam tee continues to be the bane of my existence, I had a slight leak out of the anti-vac, which was resolved with a quick tweak with a spanner, but now I have a small but persistent leak a the bottom of the steam tee *rolleyes* halfway tempted to run a tank of straight tap water through it to hopefully scale the passage, but I probably should do the "right thing", pull the boiler, pull the necessary bits out of the top of it and re-fit the steam tee again :/

                            We'll see how motivated I get.