No announcement yet.

How do you descale a plumbed in Mininova

  • Filter
  • Time
  • Show
Clear All
new posts

  • How do you descale a plumbed in Mininova

    Hi guys. I have been lucky enough to come across a great condition WEGA Mininova WX rotary pump plumbed in machine.
    It was in storage for approx 12 months and before I make the effort of plumbing it in, I want to give it a bit of TLC including a descale. I have come across threads on how to descale a reservoir model but can't find the details on plumbed in. I can't even seem to find an owners manual for this particular model (if it even exists)
    Apart from pulling it apart and filling the boiler directly, I'm not sure how to get the solution through the machine.

    Any help would be great. Thanks

  • #2
    Please wait for the correct advice. I have read that a rotary pump needs water under pressure so you place a container well above the unit and connect with a plastic pipe this supplies water under pressure to the pump. Do wait for correct advice.


    • #3
      In regards to pump feeding the machine, you just need a bit of water head to feed the pump. Pumped machines that have a built in tank have the pump head near the bottom of the tank.

      The two machines I have seen have the suction hose going over the top of the tank, so in theory they are sucking a bit to prime them selves initially.

      Have the suction hose higher than the pump head and minimise the height of the loop over the top. You can also fill the hose with water to minimise air, which is what causes issues, not good running pumps dry and also the pimps struggle sucking the air through to prime.



      • #4
        A mininova will run fine off a tank even below the pump level.
        It's always a better idea to have the tank above the pump as mentioned previously but it will draw from the tank at bench height as well.

        Remember with this machine that it has a separate hot water heat exchanger which will need to be filled with descaler.

        You will need to remove the top to access the autofill probe for filling the boiler so you might as well check for any scale evidence before going ahead with the descale process because it takes a long time.

        Remove the top nut from the group head to expose the group jet and filter mesh. See if there is any scale on either of these.
        You can also remove a fitting or valve from the boiler and have a look in and see if there is any scale. Alternatively, tilt the machine from side to side vigorously and listen for any scale flakes sloshing about inside the boiler.

        If you can't see any scale problems using these methods, the machine is probably ok and you can just start using it. Remember to fit a good quality water filtration system on the water line so you don't have to worry about scale in the future.


        • #5
          Click image for larger version

Name:	ImageUploadedByTapatalk1459051562.831269.jpg
Views:	1
Size:	315.5 KB
ID:	741796
          Thanks for the feedback guys. Looks like there is some scale in there! it will be worth a clean out I reckon

          I tried to run the coffee machine with the inlet in a bucket but it did not seem to draw the water. Whereas when I tested it with mains pressure is connected it flows fine. I did still have a filter in line so that may be part of the problem. I'll have to try it without the filter a bit later.
          Click image for larger version

Name:	ImageUploadedByTapatalk1459053703.065525.jpg
Views:	1
Size:	284.5 KB
ID:	741797

          I had so much joy tinkering and tweaking to get the most out of my old 6910 and I'm hoping that with some TLC and and some patience, this big girl will treat me right.


          • #6
            Yeah that's pretty bad scale. I'd probably soak those parts in descaler to ensure complete descaling.

            My Mininova (older one with black plastic top) operates fine off a tank, not sure why yours has problems.

            Does it even not draw water with the tank above the machine?


            • #7
              I have tried drawing water from above the machine without the filter and it still won't draw it. It's making me wonder if the pump is working correctly or not. The machine is letting hot water through the tap, the brew head and the steamer with mains pressure but I guess I won't know how well it is working until I finish descaling the brew shower screen (which looked more like tar than coffee residue. I should have taken a pic before I started cleaning it. It was a beauty!)

              Which raises the original question of if the machine will not draw from a tank... How do I get the descaler into the boiler and hx?


              • #8
                Is the pump running ok? Have you tried filling the tube with water first then seeing if it will draw?

                My old machine would sometimes not suck if the line was fully empty. Adding a bit of water got it going ok.



                • #9
                  Thanks artman. Well I think the pump may be the problem. It will not draw any water through the intake line without pressure. I thought the rotary pump was meant to be quiet and as the water (under mains pressure of course) was flowing before I did not think anything of it. Now that I am listening closely it sounds like the motor has stalled.
                  Looks like I'll need to strip the puppy down to get access to the pump/motor and have a closer inspection.
                  I'm hoping it is just a motor start capacitor that is buggered. Anyone know where I can find the cap


                  • #10
                    Coffeeparts sell many different capacitors for AC motors, they'll have the one if you require it.

                    When you have the case off, you should be able to access the back of the motor where the centre shaft can be turned manually with a flat head screwdriver, it usually has a slot cut out of it. Try turning it with the pump still attached. If you can't move it, the pump has probably seized.
                    Remove the pump from the motor then try again, the motor should turn freely.

                    If you try turning the pump input shaft it will either not move at all or struggle to rotate. If so, soak it in descaler in 10 minute intervals, taking it out to rotate the input shaft a small amount each time. Hopefully this frees it up and it will continue to work. If not, you'll need a new pump.


                    • #11
                      I removed the covers and noticed the motor wasn't rotating. Popped the pump off the motor and tested. Success. Motor fine but pump seized. With a a little gentle persuasion the pump freed up. Reassembled and whola! Machine draws from a reservoir! Then I jumped on the forum to let you guys know and I then read Noidles suggestion [emoji1]. Great minds!

                      I will now follow the thread below. Thanks guys[emoji4]


                      • #12
                        Thanks for the help guys. Machine is descaled. Then the fun began... I think I'll need to post some info in a different thread for other people stuck down the same path as me (and of course for some advise) Noidle it seems like you have been through it all before. I reckon you will be an oracle of knowledge in my circumstance.