Announcement

Collapse
No announcement yet.

Giotto Rocket group head no water

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Giotto Rocket group head no water

    Hi there, hoping someone can help. Just got a Giotto rocket and no water comes through grouphead. Followed all instructions and am at a loss. Could this be an issue with an airlock in the system?

    Thanks
    Last edited by Barry2000; 25 September 2016, 11:22 AM.

  • #2
    Is this a new machine?

    Mal.

    Comment


    • #3
      Yes it is just unpacked it today

      Comment


      • #4
        Contact the dealer you purchased it from. They will know what to do or alternatively replace/repair it as it is DOA.

        Comment


        • #5
          I'd doubt that it's a DOA. In 10 years of selling Giotto, we have never experienced one. Check water quality and that the tank is correctly seated. Pump it up and down a little in its coupling.

          Contact the operation you purchased the machine from.

          Comment


          • #6
            Thanks all, for the responses so far. I will give reseating the tank a go. The water quality is fine we are in Melb and have good quality water. When I first turned it on (used filtered water) the green light started flashing. Checked on line and the feedback was that the water was demineralised and add a pinch of salt so the machine would recognise the full tank. That worked.

            Now the boiler fills and heats up, just when it hits pressure it expels a puff of steam from top of machine, steam arm works at full pressure, and hot water flows out of the water wand. When engaging the lever for the group head the pressure gauge reads 8 bar and the pump engages, but no water flows through the group head. Shower basket is bone dry.

            PiD is at factory default on 123

            Comment


            • #7
              Originally posted by Barry2000 View Post
              Checked on line and the feedback was that the water was demineralised and add a pinch of salt so the machine would recognise the full tank.
              Don't use demineralised water. Ever.

              For this fill, use plain tap water. Let if heat. open the hot water wand until it drinks from the tank and then try again.

              Sounds to me like the operation you purchased from did not bench test your machine.

              Comment


              • #8
                Refilled using plain tap water, reseated the tank a number of times. Let it heat up, opened the hot water wand until the it drank from tank (seemed to drink longer then what I had the wand open for) operated the lever, and no change. Still no water through grouphead.

                Is is there any chance that there is an air lock?

                unboxed yesterday, but has been in storage (unopened) since Jan 2015

                Comment


                • #9
                  Ahh ok... Most likely blocked gicleur in the group (google an e-61 diagram) or less likely an issue at the solenoid.

                  Comment


                  • #10
                    when you pull the lever is the pump activating?

                    edit.... just re read your earlier post and seems pump in activating.

                    id just take it to someone and have it looked at

                    Comment


                    • #11
                      Okay, thanks for your help, think I will call the shop where it came from tomorrow and see if they can send someone out to have a look.

                      Comment


                      • #12
                        Hi JohnA, yep pump activates when lever is pulled

                        Comment


                        • #13
                          Try checking the gicleur yourself. 7mm socket and a spanner required. Easy fix if it's just a blockage.

                          The shop will charge you a callout and service fee if they have techs on the road as your machine is out of warranty.

                          Comment


                          • #14
                            Update, quick trip to Bunnings to get the right spanner (taped to make sure didn't scratch the bolts). Pull the gicleur out and the spring and plunger thingy water started to drip through the group head. Reassembled, turned on waited to reheat. Pulled group head lever and a steady stream of water came through.

                            Many Thanks to >Talk_Coffee for the step though trouble finding techiniques.

                            Now on to learning how how to make better coffee.

                            Thanks to all forum members who came up with suggestions on how to fix

                            Comment


                            • #15
                              great turn out, and great help from one of the sponsors on here.
                              Chris to the rescue again.

                              Comment

                              Working...
                              X