Announcement

Collapse
No announcement yet.

Nuova Simonelli Musica not turning on

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Nuova Simonelli Musica not turning on

    My Musica has been giving me great service for 5 years. I had not used the machine for a week. When I made my first espresso, my presets were gone and the manual selection just ran for a short while. I reset the programmed selection after which the manual selection operated as normal again. The next day when I started the machine it had the tank empty light on intermittently, there was water in the tank. I lifted the tank in and out twice, this solved the problem and the machine worked like normal for the rest of the day.The next day when I turned the machine on, it started with the same issue, showing tank empty intermittently and I could hear a solenoid switching. This carried on for a few seconds and then the machine turned off. The on/of switch on the selection panel has its light on, but if you press it the rest of the lights on the service panel just flashes once and then nothing happens. It won’t turn on. Can somebody please give me some advice on what the problem could be. I am a long way from a service centre.

  • #2
    Hey!
    I have run into the same problem. Had intermittent tank warning for a few days, and now it won’t even start up. The whole panel just flashes once and then shuts back down. Have you found a way to solve it?

    Comment


    • #3
      Hi

      I replaced the control panel and main print board and the machine was working again, but the magnetic low level sensor was not working.

      I bought a new tank and the problem was solved.

      You can check the magnetic sensor with another magnet. Its cheaper starting the fault finding with a new tank.

      Comment


      • #4
        Good to hear you’ve got yours sorted out and working again.

        I’ve had similar low water sensor detection on Oscar II but was able to see it as it happened when pouring in new water to the tank. The magnet / float looks like it can get stuck. Thankfully ours shifted and was back working again. [emoji92]

        Comment


        • #5
          Hi AFVN codan, were yous able to isolate which board was the culprit? I am experiencing the exact same issue and want to avoid having to replace both boards unless really necessary...

          Comment


          • #6
            Ok so for reference if anyone else experiences a similar issue... I managed to get the main board repaired for a few $ at my local electronics repair shop, was going to attempt it myself as part cost next to nothing but a few $ rather get someone to do it than dig out my rusty iron...
            The component that usually goes bad is the electrolytic capacitor next to the transformer (top left on old style board and bottom left next to keypad cable on new style board). The part is a 35V 470uF capacitor, if you look at the top and it is not perfectly flat and has slight bulge it is bad, I also checked with ESR meter in circuit, if good it should read something like 0.2 Ohms or less (note this is ESR, not regular resistance measurement).
            If it is not that and you need to replace the board, old style boards no longer available and I was told that you would need to replace both main board and keypad if going from old to new style.
            Hope that helps other ppl in similar situation.

            Comment


            • #7
              Great feedback there. Might replace mine as a preemptive

              Comment


              • #8
                Was a bit of a pain to pull out all the connectors, maybe good to get a few spare caps so ready to replace if/when it does fail...

                Comment

                Working...
                X